PDA

Visualizza la versione completa : /bin/bash: bad interpreter


pazx
28-09-2004, 18:57
Ciao a tutti.
Facendo un update con Apt su SuSE 9.1 si è corrotto (si dice cosi? :fagiano: )il silesysteme rovinata l'immagine del kernel .
Ho rispristinato (almo speravo di averlo fatto) il filesystem e sistemato il kernel.

Tuttavia se provo a compilare un programma mi succede questo:

pazx@linux:~/download/aMule-1.2.8> /bin/bash ./configure
bash: ./configure: /bin/bash: bad interpreter: Permission denied

I permessi di esecuzione per la bash dovrebbero essere quelli giusti, anche perchè così funziona:

pazx@linux:~/download/aMule-1.2.8> /bin/bash ./configure
lavora bene.

Questo mi succede tutte le volte che provo a compilare.
Che faccio?

:fagiano: :rollo:
Ciao e grazie

adarkar
28-09-2004, 19:09
perchè non lasci che scelga da solo con cosa eseguire il configure invece di imporre bash? :master:

pazx
28-09-2004, 19:14
Chiedo scusa ho sbagliato a riportare l'errore:

pazx@linux:~/download/aMule-1.2.8>./configure
bash: ./configure: /bin/bash: bad interpreter: Permission denied

lo sceglie da solo la bash
:stordita:

Ilmalcom
28-09-2004, 19:17
:dottò:


ls -l /bin/bash

pazx
28-09-2004, 19:19
-rwxr-xr-x 1 root root 447064 2004-04-06 03:39 bash
:dhò:

Loading