PDA

Visualizza la versione completa : adsl con router


francofait
01-10-2004, 19:15
Originariamente inviato da ciromosketta
Dopo aver configurato la scheda di rete con un ip statico, modificando il file
/etc/rc.inet1.conf (Slackware), ed averla collegata al router, cosa devo
impostare ulteriormente per poter navigare, visto che non ci riesco? il gateway
(che sarebbe poi l'ip del router), giusto?

Penso proprio che si - ma se on hai altre macchine collegate al ruter dell' ip statico he te ne fai ?, imposta dhcp attivo.

Pegasus
01-10-2004, 19:49
Originariamente inviato da ciromosketta
Dopo aver configurato la scheda di rete con un ip statico, modificando il file
/etc/rc.inet1.conf (Slackware), ed averla collegata al router, cosa devo
impostare ulteriormente per poter navigare, visto che non ci riesco? il gateway
(che sarebbe poi l'ip del router), giusto?

Beh il dns, la submask, il broadcast li hai impostati?

Trotto@81
01-10-2004, 20:28
Originariamente inviato da Pegasus
Beh il dns, la submask, il broadcast li hai impostati?

Io non posso aiutarlo perchè non so niente di queste cose, ma non potreste spiegare passo passo come fare dato che è così semplice??
Ho notato che l'argomento è poco trattato nel forum.

francofait
01-10-2004, 23:16
Non capisco che bisogno c'era di mettere mano hai file di configurazione -
Il ruter la connessione l'ha già disponibile configurata ed attiva x i cavoli suoi . Con Slackware bastava attivare la scheda di rete in rc.modules e riavviare il sistema x defaults ti rende comunque dhcp attivo una volta riavviato navighi subito senza bisogno di nulla.
Se poi puoi mantienenere attivo anche hotplug senza che ti dia problemi , non hai neppur bisogno di metter mano a rc.modules tanto la scheda di rete te la rileva da se.

francofait
01-10-2004, 23:28
Originariamente inviato da ciromosketta
sì la scheda di rete era ok, però non navigavo! il router era connesso, ma sul pc non riuscivo a navigare, per quanto ne possa capire credo che fosse la mancanza del gateway nelle tabelle di routing

Questo perchè quando hai fatto l'installazione invece di passargli attivare l'ip dinamico ai mantenuto lo statico di defaults , comunque anche in questo caso bastava mettere l'indirizzo di gatewai in /etc/resolv.conf

gigyz
02-10-2004, 09:21
:biifu:
che c'entrano il gateway e le tabelle di routing con il resolv.conf ? :master:
per aggiungere il gateway fai
route add default gw ip_del_router
poi se il router fa pure da dns metti
nameserver ip_del_router
in resolv.conf altrimenti gli metti i DNS del provider

francofait
02-10-2004, 09:43
Originariamente inviato da gigyz
:biifu:
che c'entrano il gateway e le tabelle di routing con il resolv.conf ? :master:
per aggiungere il gateway fai
route add default gw ip_del_router
poi se il router fa pure da dns metti
nameserver ip_del_router
in resolv.conf altrimenti gli metti i DNS del provider

Se è per me, non ho bisogno di metterci nulla e neppure ne ho mai avuto salvo quando l'ho comprato e installato , eppure su partiz. mordi e fuggi installo e metto alla prova nuove distro quasi tutti i giorni.
Per quel che mi risulta è sufficente che il SO riconosca la scheda di rete .e nulla di più.

Loading