PDA

Visualizza la versione completa : ki sta usando la mia scheda audio?


alex86
09-10-2004, 16:54
ho un problema..oggi xmms non vuole saperne di funzionare..

ho aperti gli stessi programmi ke uso sempre e non riesco a capire ki stia usando la mia skeda audio..

se avvio un mp3 mi esce la finestra ke dice ke è occupata...e da ki?.. :dhò:

Ikitt
09-10-2004, 16:59
Originariamente inviato da alex86
ho aperti gli stessi programmi ke uso sempre e non riesco a capire ki stia usando la mia skeda audio..


(0gg1 m1 z3nt0 l33t :D )

z3 uz1 0ss, puo1 sk0pr1rl0 d4nd0 d4 r00t il k0m4nd0


# fuser -v /dev/dsp

Ke plug1n uzi p3r l'0utput k0n xmms?

+++

(rilegge)
Bah, meglio che torni a studiare :stordita:

alex86
09-10-2004, 17:04
Originariamente inviato da Ikitt
(0gg1 m1 z3nt0 l33t :D )

z3 uz1 0ss, puo1 sk0pr1rl0 d4nd0 d4 r00t il k0m4nd0


# fuser -v /dev/dsp

Ke plug1n uzi p3r l'0utput k0n xmms?

+++

(rilegge)
Bah, meglio che torni a studiare :stordita:

intanto tengo a dire ke non scrivo proprio così..almeno i miei post sono comprensibili!

poi, dando quel comando sia da utente ke da root non mi esce niente..

alex86
09-10-2004, 18:09
piccolo ma significante aggiornamento..

questo accade solo con xmms...
con mplayer nessun problema!

come mai?!..non ho modificato nessuna impostazione di xmms..
l'ho anke reistallato ma niente..

gianiaz
09-10-2004, 18:27
controlla quale server sonoro usa xmms.
Se usi gli oss, puoi usarli con un programma solo alla volta.
Con alsa ti permette di usare i device audio da diversi programmi contemporaneamente.

alex86
09-10-2004, 18:34
...c'è "Riconoscimento automatico"..

se metto alsa dà sempre lo stesso errore!

adarkar
09-10-2004, 19:00
Originariamente inviato da Ikitt
(0gg1 m1 z3nt0 l33t :D )


:maLOL:



z3 uz1 0ss, puo1 sk0pr1rl0 d4nd0 d4 r00t il k0m4nd0


# fuser -v /dev/dsp



3 z3 uz4 4lz4 1nv3c3 fuz3r n0n funz10n4? :master: :master:

Ikitt
09-10-2004, 19:33
Originariamente inviato da alex86
intanto tengo a dire ke non scrivo proprio così..almeno i miei post sono comprensibili!
Urca! sembri alquanto suscettibile :dottò:
Chiaramente puoi scrivere come vuoi e non sta a me correggerti. D'altra parte, chiudendo l'inciso, a me ogni tanto piace scrivere in l33t (o in HEX) e per giunta il mio post mi pareva comprensibile, tant'e` che adarkar ha anche risposto a tono. Ma questo e` argomento da forum di italiano, non di linux ;)


poi, dando quel comando sia da utente ke da root non mi esce niente..
capito. Interessante.
Dunque: che sistema audio usi nel kernel? OSS? ALSA?
Usi un server sonoro? (jack, arts, esd...)
Se lo fa solo xmms e` un problema di xmms, altrimenti il problema e` da ricercarsi nella configurazione -appunto- del sistema o del server sonoro; se usi alsa basta impostare i vari programmi per alsa, altrimenti e` consigliabile o passare ad alsa o impostare xmms & co per appoggiarsi al server sonoro.

Ikitt
09-10-2004, 19:38
Originariamente inviato da adarkar
3 z3 uz4 4lz4 1nv3c3 fuz3r n0n funz10n4? :master: :master:

n0, 3` ke kon 4lz4...
Uhm, cough cough, scusate.
Dicevo: no, e` che con alsa questo problema non dovrebbe verificarsi. Il fatto e` che -da quel che so-, con OSS solo un client in userspace per volta puo` accedere ai servizi della scheda audio. Se il programma XXX apre (e tiene aperto) /dev/dsp, qualsiasi altro prog si vedra` recapitato un bel "access denied" e conseguentemente restera` muto.
Non so se e` una limitazione dell'API, del driver o di che altro, fatto sta che in tutti i casi a me noti con OSS e` andata cosi`.
Questo e` uno dei motivi per cui hanno introdotto i server sonori (esd, arts...), per consentire la riproduzione di piu` flussi audio contemporaneamente da parte di piu` applicazioni.

ALSA non ha questa limitazione, e puo` quindi fare a meno, per questo specifico aspetto, del server sonoro.

Questo e` il motivo per cui fuser e` utile principalmente se si usa OSS (o anche l'emulazione OSS di ALSA? Devo verificare...), altrimenti l'informazione ottenuta non e` molto significativa.

Il tutto IIRC & AFAIK, ovviamente.

chaosd
09-10-2004, 19:38
metti in centro di controllo kde che il server sonoro (dedicato a kde) debba spegnersi dopo 1 secondo di inattività

Loading