PDA

Visualizza la versione completa : driver invidia non vano


pauloref
10-10-2004, 22:45
io ho gentoo, e un kernel development-2.6.7. Va tutto, trane i driver nvidia, e quando do:

emerge nvidia-kernek

mi da l'errore seguente:

*
* Could not determine your kernel version.
* Make sure that you have /usr/src/linux symlink.
* And that said kernel has been configured.
* You can also simply run the following command
* in the kernel referenced by /usr/src/linux:
* make include/linux/version.h
*

!!! ERROR: media-video/nvidia-kernel-1.0.6111-r2 failed.
!!! Function check_KV, Line 253, Exitcode 0
!!! (no error message)

qualchuno ha qualche sugestioni??

andy caps
10-10-2004, 22:47
in /usr/src linux deve puntare al kernel in uso

dai un uname -r e un ls -l /usr/src e controlla

pauloref
10-10-2004, 22:57
l'ho gia fatto, ecco quello che mi da se faccio ls -l:

lrwxrwxrwx 1 root root 26 Oct 3 19:39 linux -> linux-2.6.7-development-r6

il mio kernel in fatto un development-2.6.7. E tutto giusto.
Qualche altra sugiestione?

Per favore. AIUTO

andy caps
10-10-2004, 23:09
:bh: sei mica da chroot ?
da chroot non si installano i driver nvidia

l'errore lo dice chiaramente che non il kernel giusto

pauloref
10-10-2004, 23:14
no, e da un pezzo che il mio sistema e funzionante, e sono dal mio sistema. Si, sono logato come utente e poi do "su".
Ma il miokernel e un 2.6.7, e per instalarlo ho dato "emerge development-sources" dunque un development kernel. Come facio a sapere con precisione che kernel e per dare "ln"?

andy caps
10-10-2004, 23:20
digita uname -r

ed incolla
poi dai un ls -l /usr/src
ed incolla

pauloref
10-10-2004, 23:39
eco uname -r :

2.6.7

eco ls -l:

lrwxrwxrwx 1 root root 26 Oct 3 19:39 linux -> linux-2.6.7-development-r6
drwxr-xr-x 19 root root 1296 Oct 10 01:13 linux-2.6.7
drwxr-xr-x 3 root root 72 Oct 5 21:19 xorg-x11-6.7.0-r1

una cosa strana e che linux -> linux-2.6.7-development-r6 stava lampegiando.

andy caps
10-10-2004, 23:43
si devi andare in /usr/src

rm linux

ln -s linux-2.6.7 linux

semplicemente poi ridai emerge nvidia-kernel nvidia-glx

pauloref
10-10-2004, 23:49
ho provato, ma eco il risultato di emerge nvidia-kernel:

* A dry-run of patch command succeeded, but actually
* applying the patch failed!

* Failed Patch: nv_enable_pci.patch!
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/nvidia-kernel-1.0.6111-r2/temp/nv_enable_pci.patch-7912.out

pauloref
10-10-2004, 23:52
e quando ho dato emerge nvidia-glx mi ha dato un altro errore:

* Due to inconsistencies in xorg-x11 vs xfree handling of glext.h a userspace
* is necessary for you to use opengl-update-1.8; Please do the following

* mv /usr/X11R6/include/GL/glext.h /usr/lib/opengl/xorg-x11/include

* You may then remerge opengl-update-1.8.1 successfully


!!! ERROR: x11-base/opengl-update-1.8.1-r1 failed.
!!! Function pkg_setup, Line 39, Exitcode 0
!!! Userspace problem needs fixing

AIUTO, ANCORA

Loading