PDA

Visualizza la versione completa : winXP mi ha distrutto la tabella delle partizioni


sopadj1
11-10-2004, 20:12
salve gente!!!! 2 sono le cose: o sono io che sono deficente o winXP mi ha veramente corrotto la tabella delle partizioni, se cosi si chiama.

ecco la storia:

tanto tempo fa, avevo un hd cosi partizionato

hda1 (niente,10mb)
hda3 (win2k)
hda5 (fat32 x scambio dati)
hda6 (swap)
hda7 (30 giga liberi, aspettando il/i dvd della debian)
hda8 (mandrake)
hda9 (slackware)
hda10 (6 gb vuoti)

allora mi sono detto: mio fratello ha winxp, ora installo winxp in hda10 cosi ha un muletto con cui fare esperimenti...

avvio l'installazione di winxp e dopo un po mi da errore dicendomi che c' un errore nella tabella delle partizioni!!! :nonlodire

avvio, tramite il cd della suse9.1 , la mandrake e, cercando di ripristinare grub, mi accorgo che hda3 non c' !!!!!

:nonlodire :nonlodire :nonlodire

allora decido, dopo 176 bestemmie, di reinstallare la mandrake (non so usare mknod per ricreare il dispositivo)

ma, quando devo selezionare le partizioni, durante l'installazione, mi accorgo che hda3 non c' !!!!!


:cry: :cry: :cry: :cry:

sopadj1
11-10-2004, 20:25
:( ... :madai!?: .... :stordita: .... :cry:

Caleb
11-10-2004, 20:41
prova questo

http://www.ranish.com/part/

sopadj1
11-10-2004, 20:59
Originariamente inviato da Caleb
prova questo

http://www.ranish.com/part/

ma 1 applicativo che gira sotto windows????

proprio la partizione dove sta installato windows che non mi riconosce!!!!

il mbr se ne andato a p*****e , qualunque distro che avvio, e , durante l'installazione, decido di partizionare manualmente l'hd , non mi riconosce hda3 !!!!

non me lo vede!!! cosa potuto succedere?

sopadj1
11-10-2004, 21:30
quanto sono imbecille??!!!!

ora hda1 , invece di essere piccolo, grande 10 gb (quindi si incorporato hda3) pero' ora ho un problema!!!

avvio la mandrake(con la quale gestisco il bootloader nel mbr) e cerco di aggiustare il bootloader, se nn inserisco la voce di windows che ha la root in /dev/hda1 funziona , ma se inserisco appunto la nuova partizione di win2k , cio hda1, mi da errore:

Warning : 'menu-scheme' not supported by bootloader
Device 0x0300 : inconsistent partition table, 1st entry

CHS address in PT: 1:1:1 -> LBA (1071)
LBA address in PT : 16128 -> CHS (16:0:1)

fatal : either FIX-TABLE or IGNORE TABLE must by specified

if not sure, first try ignore table (-P ignore)

help help !!!!

devo reistallare windows sulla nuova hda1????

Caleb
11-10-2004, 21:56
ma hai provato il programma che ti ho detto? non gira sotto windows, procurati un disco di avvio del 98se da bootdisk.com e copiacelo sopra... all'avvio dovrebbe rilevare da solo l'errore sulla tabella e correggertelo

altor
11-10-2004, 23:46
Originariamente inviato da sopadj1
mi da errore:

Warning : 'menu-scheme' not supported by bootloader
Device 0x0300 : inconsistent partition table, 1st entry

CHS address in PT: 1:1:1 -> LBA (1071)
LBA address in PT : 16128 -> CHS (16:0:1)

fatal : either FIX-TABLE or IGNORE TABLE must by specified

if not sure, first try ignore table (-P ignore)

help help !!!!

devo reistallare windows sulla nuova hda1????

L'altra sera ho avuto un errore analogo.
Ho dato retta al warning e (proprio "a pappagallo", devo ammettere) ho scritto sul lilo che non andava proprio:
IGNORE-TABLE (non ricordo come era con o snza trattino, ma l'ho copiato).
Con mia sorpresa (lo ammetto) partito tutto!
L'dea che mi son fatto che in questo modo lilo se ne sbatte della differenza fra le partition table....
Ciao!

sopadj1
11-10-2004, 23:55
Originariamente inviato da Caleb
ma hai provato il programma che ti ho detto? non gira sotto windows, procurati un disco di avvio del 98se da bootdisk.com e copiacelo sopra... all'avvio dovrebbe rilevare da solo l'errore sulla tabella e correggertelo

ma dopo aver preso il floppy di avvio di win98 seconda edizione, devo unzippare il file che mi hai linkato tu e copiarci tutti i file nel floppy in questione???

@altor

non ho avuto tempo di approfondire ma....ho provato 3 volte a reinstallare il grub nel mbr ma non me lo installa!!!

strano, dovo il bios parte direttamente la mandrake!!!!!

ps: possibile che windows mi abbia preso lo spazio dell' mbr ????

KornShell
11-10-2004, 23:57
windows pretende di essere installato solo in una partizione primaria del disco, leggi da hda1 ad hda4

sopadj1
12-10-2004, 00:01
Originariamente inviato da KornShell
windows pretende di essere installato solo in una partizione primaria del disco, leggi da hda1 ad hda4

:stordita: e ora come risolvo??

Loading