PDA

Visualizza la versione completa : come cambiare PKG_CONFIG_PATH ???


Ali79
12-10-2004, 17:44
Nuova settimana, nuovo problema
Sto cercando di installare gdesktop ( un programma che serve per rendere gnome simile ai Mac *_*)
Per installarlo devo prima compilare i seguenti pacchetti:
pygtk-2.4.0.tar.bz2
gnome-python-2.6.0.bz2

Ho compilato pygtk-2.4.0.tar.bz2 e tutto andato a posto (almeno credo)
Poi Ho cato ./confgure per gnome-python mi dice questa cosa:


checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.3/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.3/site-packages
checking for headers required to compile python extensions... found
checking for pkg-config... /usr/bin/pkg-config
checking for pygtk-2.0 >= 2.4.0... Package pygtk-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pygtk-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'pygtk-2.0' found

configure: error: Library requirements (pygtk-2.0 >= 2.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Che devo fare. Io l'ho installato. Non so che cosa devo cambiare? Se edito il file pkg-config vengono fuori dei caratteri strani.

Quancuno mi sa dare una manina?

gianiaz
12-10-2004, 19:57
Prima di parlare di PKG_CONFIG_PATH controlla di aver installato il pacchetto richiesto:

pygtk-2.0

un modo veloce per verificare:

updatedb ; locate pygtk-2.0.pc

Se non ti da nessun output significa che ti manca il file cercato, fornito dal pacchetto segnalato sopra.

ciao

Ali79
12-10-2004, 23:54
E infatti non c'. Per adesso non capisco una cosa, ma se il pacchetto pygtk-2.4.0.tar.bz2 l'ho installato e durante l'installazione non ci sono stati errori, come mai non c' quel file?
:dh: :confused: :dh:

KornShell
13-10-2004, 00:26
ulteriore verifica, apri un terminale e digita python
poi passa all'interprete i comandi

import pygtk
pygtk.require("2.0")

se non ti da nessun errore installato
qui sotto quello che devi vedere


liquid@jupiter ~ $ python
Python 2.3.4 (#1, Oct 6 2004, 00:04:11)
[GCC 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pygtk
>>> pygtk.require ("2.0")
>>>

gianiaz
13-10-2004, 09:34
Non so quale distro usi, ma in debian il file che tu cerchi contenuto nel pacchetto di development.

python-gtk2-dev

Credo che non tutte le distro facciano questa distinzione per...

:ciauz:

Loading