PDA

Visualizza la versione completa : [gentoo] alsa e udev


adarkar
15-10-2004, 15:38
salveee :zizi:

dunque ho seguito la mia solita paginetta della doc..
installare alsa-utils
sistemare modulame ecc..
ho fatto tutto e l'unica differenza tra adesso e quando andava era devfs/udev nel senso che adesso ho udev
i file /dev/dsp e compagni comunque esistono e hanno i permessi giusti.. com' che mi fa questo bello scherzetto:


# amixer set Master 100 unmute
amixer: Unknown playback setup 'unmute'..

# amixer set PCM 100 unmute
amixer: Unable to find simple control 'PCM',0

??
al master mi cambia il volume ma non toglie il muto
mentre il pcm proprio non lo vede, com' la storia? :fagiano: :fagiano:

se provo a suonare qualcosa sembra che vada tranquillamente.. ma c' il mixer muto :bh:

thx!! :ciauz:

GhePeU
15-10-2004, 15:52
controlla il contenuto di /dev/sound/

che udev stai usando? l'ultimissima versione (038) mi ha dato qualche problema con alsa quindi per ora son tornato alla 036

adarkar
15-10-2004, 15:59
pare che ho udev 030

sound l'ho controllata e ho messo a tutto perm 660:


root # ls -l /dev/sound/
total 0
crw-rw---- 1 root audio 14, 4 Oct 11 23:32 audio
crw-rw---- 1 root audio 14, 3 Oct 11 23:32 dsp
crw-rw---- 1 root audio 14, 0 Oct 11 23:32 mixer
crw-rw---- 1 root audio 14, 1 Oct 11 23:32 sequencer
crw-rw---- 1 root audio 14, 8 Oct 11 23:32 sequencer2

:bh:

GhePeU
15-10-2004, 16:13
scusa, intendevo /dev/snd

adarkar
15-10-2004, 16:23
uguale :)


root # ls -l /dev/snd/
total 0
crw-rw---- 1 root audio 116, 0 Oct 11 23:32 controlC0
crw-rw---- 1 root audio 116, 24 Oct 11 23:32 pcmC0D0c
crw-rw---- 1 root audio 116, 16 Oct 11 23:32 pcmC0D0p
crw-rw---- 1 root audio 116, 1 Oct 11 23:32 seq
crw-rw---- 1 root audio 116, 33 Oct 11 23:32 timer


btw.. non ci sarebbe un modo per disattivare "temporaneamente" udev, e quindi usare i dev static per dsp e company?

adarkar
16-10-2004, 19:02
riciao!
allora siccome pensavo fosse udev ho fatto un nuovo kernel con devfs.. per non cambia nulla!
il problema che ho diagnosticato io che invece di cercare la mia scheda alsa cerca di usare la dummy.. e le conseguenze sono quindi facilmente intuibili..

ora, in /etc/modules.d/alsa c' questo:
alias snd-card-0 snd-via82xx
i moduli ci sono ecc ecc
sapete mica come si fa a dirgli di andare a prendere la scheda giusta? :fagiano: :fagiano: :fagiano:

thx!!

andy caps
16-10-2004, 19:23
in /etc/modules.autoload.d hai messo i vari moduli ?

mettici anche
soundcore
snd


mettendoli statici nel kernel certi moduli a volte creano problemi

adarkar
16-10-2004, 19:25
non so se mi spiego......
io vi posto una cosa, se qualcuno si intende vagamente di alsa risponda per favore perch non capisco proprio cosa stia facendo!!



[root@pygo ~] # modprobe snd-via82xx
[root@pygo ~] # lsmod
Module Size Used by
snd_via82xx 24580 0
snd_ac97_codec 65156 1 snd_via82xx
snd_mpu401_uart 7040 1 snd_via82xx
snd_rawmidi 21156 1 snd_mpu401_uart
[root@pygo ~] # grep via /etc/modules.d/alsa
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx
[root@pygo ~] # /etc/init.d/alsasound start
* ALSA Detected...
* Restoring Mixer Levels [ ok ]
[root@pygo ~] # lsmod
Module Size Used by
snd_via82xx 24580 0
snd_ac97_codec 65156 1 snd_via82xx
snd_mpu401_uart 7040 1 snd_via82xx
snd_rawmidi 21156 1 snd_mpu401_uart
[root@pygo ~] # amixer -c 0 info
Card hw:0 'Dummy'/'Dummy 1'
Mixer name : 'Dummy Mixer'
Components : ''
Controls : 10
Simple ctrls : 5


:bh: :bh: :bh: :bh:

adarkar
16-10-2004, 19:26
soundcore e snd dici? :fagiano: :fagiano: :fagiano:
controllo subito!!!!!! :messner:

adarkar
16-10-2004, 19:30
:fagiano: :fagiano: :fagiano:

ehm dove li trovo quei moduli l nel menuconfig? :fagiano: :fagiano: :fagiano: :fagiano:
<*> Sound card support
questo qui? :fagiano: :fagiano:

Loading