PDA

Visualizza la versione completa : che cosa gtk_combo?


Ali79
17-10-2004, 22:39
Vorrei compilare questa utility che dovrebbe servire ad installare i temi di gtk senza usare gnome: gtk-xfce-engine-default-2.1.10.tar.tz
scaricata da questo sito:
http://www.muhri.net/nav.php3?node=gts

ho dato il comando make ma mi da questo errore:

object-2.0 -lgmodule-2.0 -ldl -lglib-2.0
switch.c: In function `preview_clicked':
switch.c:129: warning: implicit declaration of function `GTK_COMBO'
switch.c:129: error: invalid type argument of `->'
switch.c: In function `apply_clicked':
switch.c:160: error: invalid type argument of `->'
switch.c: In function `dock':
switch.c:342: warning: implicit declaration of function `gtk_combo_new'
switch.c:342: warning: assignment makes pointer from integer without a cast
switch.c:344: warning: implicit declaration of function `gtk_combo_set_popdown_strings'
make: *** [switch] Error 1

che cosa gtk_combo? E come posso risolvere il problema?

KornShell
17-10-2004, 22:41
gtk_combo un widget delle librerie GTK
il configure non ti ha dato nessun errore?

Ali79
17-10-2004, 23:24
non bisogna dare il configure.

Questo quello che viene detto per l'installazione per come lanciarlo, solo che io non so come si fa :(

"I find my self using gnomecc all the time to switch to themes that I know I like and that I know their names, its sort of an overkill to run control-center and choose the theme - hit apply, etc.. I always have a terminal open though :) so I wrote this command line util that you pass a theme dir and it will apply it just like gnomecc does. Also it has an optional GUI in Gtk like the one you see in the shot if passed the --preview or --dock switch.
To use it, download it and untar it - run make .. and make install if you like, then:
switch --help to see what options you can have or just run switch without arguments for the theme dock."


Devo dare "make" e "make install"
:(

KornShell
17-10-2004, 23:28
gtk-theme-switch la conosco bene, hai installate le librerie gtk-devel?
Che distro usi? sicurmante troverai il pacchetto precompilato

Ali79
17-10-2004, 23:53
uso slackware 10

KornShell
18-10-2004, 00:31
estimatori di slackware si facciano avanti....Io su slackware calo il veto :rollo:

gio14
18-10-2004, 02:31
Prova ad installare libgtk1.2-dev e libgtk2.0-dev

Ali79
18-10-2004, 12:03
ma se ceroc su internet quei pacchetti mi vengono fuori solo informazioni per debian ?_?
nessuno sa dove posso trovarli per slackware?

Ali79
18-10-2004, 12:10
oppure devo semplicemente scaricare la versione development delle librerie gtk?

Cimi
18-10-2004, 15:58
scaricati il gtk theme switch gi in tgz binario da linuxpackages.net

Loading