PDA

Visualizza la versione completa : X esperti USB


Exploit
22-10-2004, 17:33
Da una settimana stò cercando di installare una fotocamera USB della sony, modello DCS-F505. --S.O SUSE 9.1--

Ho provato con tutte le salse ma con scarsi risultati, mi son buttato con google ma non ne vado fuori.

In /etc/fstab ho messo questa stinga:

/dev/sda7 /mnt/Sony vfat defaults,rw,user,noauto 0 0
anche se metto sda,sda1, ecc...ecc....non cambia niente.

Quando cerco di montarlo, se ne esce questo msg:

Vigor10:/home/exploit # mount /mnt/Sony
mount: /dev/sda7 non un dispositivo di blocchi valido


In definitiva ho caricato i moduli [USB-STORAGE]
infatti se faccio "lsusb" mi esce:

Bus 002 Device 001: ID 0000:0000
Bus 001 Device 005: ID 054c:0010 Sony Corp. DSC-S30/S70/S75/F505V/F505/FD92 Cybershot/Mavica Digital Camera
Bus 001 Device 002: ID 046d:c016 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000

Ma i log mi dicono questo:

Vigor10:/home/exploit # tail -f /var/log/messages
Oct 22 16:24:47 (none) kernel: sda: assuming Write Enabled
Oct 22 16:24:47 (none) kernel: sda: assuming drive cache: write through
Oct 22 16:24:47 (none) kernel: sda:<3>Buffer I/O error on device sda, logical block 0
Oct 22 16:24:47 (none) kernel: Buffer I/O error on device sda, logical block 0
Oct 22 16:24:47 (none) kernel: Buffer I/O error on device sda, logical block 262143
Oct 22 16:24:47 (none) kernel: Buffer I/O error on device sda, logical block 262143
Oct 22 16:24:47 (none) kernel: Buffer I/O error on device sda, logical block 0
Oct 22 16:24:47 (none) kernel: ldm_validate_partition_table(): Disk read failed.
Oct 22 16:24:47 (none) kernel: Buffer I/O error on device sda, logical block 0
Oct 22 16:24:47 (none) kernel: unable to read partition table
Oct 22 16:24:47 (none) kernel: unable to read partition table
Oct 22 16:24:53 (none) kernel: sda : READ CAPACITY failed.
Oct 22 16:24:53 (none) kernel: sda : status=0, message=00, host=7, driver=00
Oct 22 16:24:53 (none) kernel: sda : sense not available.
Oct 22 16:24:53 (none) kernel: sda: assuming Write Enabled
Oct 22 16:24:53 (none) kernel: sda: assuming drive cache: write through
Oct 22 16:24:53 (none) kernel: sda : READ CAPACITY failed.
Oct 22 16:24:53 (none) kernel: sda : status=0, message=00, host=7, driver=00
Oct 22 16:24:53 (none) kernel: sda : sense not available.


Qualche dritta???

Non mi tocchera tornare a win per ottenere certe cose Czzzzz

pdpmpd
22-10-2004, 17:57
hai provato a fare un'immagine di sda1 e a montarla in loopback?
mi è capitato di avere un problema simile con un dispositivo di mass storage della siemens, che non sono stato in grado di montare direttamente, ma solo col trucco dell'immagine.

Exploit
22-10-2004, 18:05
Inanzitutto grazie della risposta.....

Sai dirmi la procedura, non l'ho mai fatto

pdpmpd
22-10-2004, 18:08
$ dd if=/dev/sda1 of=sony.img

crea l'immagine (dovrà leggere tutta la memoria - ammesso che sia leggibile - quindi ce ne mette)

se la prima operazione va a buon fine, puoi montarla:

# mount sony.img -tvfat /mnt/Sony -o loop

Exploit
22-10-2004, 18:16
Niente non funge neanche così, non so cosa pensare :master:

Vigor10:/home/exploit # dd if=/dev/sda of=sony.img
dd: lettura di `/dev/sda': Input/output error
entrati 0+0 record
usciti 0+0 record
Vigor10:/home/exploit # mount sony.img -tvfat /mnt/Sony -o loop
mount: tipo fs errato, opzione non valida, superblocco su /dev/loop0 danneggiato,
o troppi file system montati
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
Vigor10:/home/exploit #

Exploit
22-10-2004, 18:39
Su suse plugger mi viene riconosciuta come Sony DCS F505, ma me la colloca in unità disco???? "strano".

Mi da la possibilità di configurarla, mi fa fare il login di root, e mi spara dentro alla partizione dei dischi????

E' come se volesse farmi partizionare.

E' fuori completamente :master:

almafer
22-10-2004, 18:51
provato a formattare la card di memoria dalla fotocamera stessa?

Exploit
22-10-2004, 19:01
Si avevo provato, ma nulla.

Confido nella vostra esperienza ormai :madai!?:

pdpmpd
22-10-2004, 19:24
la legge almeno la partition table? (# fdisk -l /dev/sda)

(volevo precisare una cosa, anche se non risolverà il tuo problema: quando fai l'immagine della memoria devi leggere dalla partizione sda1, non da tutto il dispositivo sda, altrimenti l'immagine risulterà non-montabile).

Exploit
22-10-2004, 19:41
Originariamente inviato da pdpmpd
la legge almeno la partition table? (# fdisk -l /dev/sda)

(volevo precisare una cosa, anche se non risolverà il tuo problema: quando fai l'immagine della memoria devi leggere dalla partizione sda1, non da tutto il dispositivo sda, altrimenti l'immagine risulterà non-montabile).


Sembra di si, riguardo al discorso di prima avevo capito giusto, non ti preocupare...........

grazie della disponibilità :ciauz:

SUSE-ROOT:/home/exploit # fdisk -l /dev/sda
SUSE-ROOT:/home/exploit #

Loading