PDA

Visualizza la versione completa : Nuovo problema con MDK10.0


Mappo
29-10-2004, 15:31
Ciao a tutti.
Ho un'altro problema e come al solito non riesco a risolverlo. :cry:
Installata la MDK 10.0 ho proceduto con l'installazione dei driver eciadsl 0.9-2 per configurare il modem usb d-link dsl 200. In seguito ho disabilitato il dabusb, creato il file di configurazione con eciconf.sh e, come avevo fatto con la MDK 9.2, ho usato eci-doctor.sh per vedere se era tutto a posto.
Il risultato :

[root@localhost mappo]# eci-doctor.sh
You are using linux kernel version 2.6.3-7mdk
Support for USB is OK
Preliminary USB device filesystem is OK
dabusb module is not loaded: OK
ehci-hcd module is not loaded: OK
OHCI support is missing... trying to load
OHCI support: failed to load
I found no USB controller

il che non mi sembra proprio bene :dh:
Ho provato a vedere cosa mi diceva lsmod, ma non ci capisco niente ...

[root@localhost mappo]# lsmod
Module Size Used by
sg 38044 0
st 38616 0
sr_mod 17028 0
sd_mod 16832 0
scsi_mod 114648 4 sg,st,sr_mod,sd_mod
mga 110976 30
lp 12200 0
parport_pc 32832 1
parport 38952 2 lp,parport_pc
es1371 33280 0
soundcore 9248 1 es1371
gameport 4480 1 es1371
ac97_codec 17804 1 es1371
af_packet 20520 0
hid 53312 0
ide-floppy 18752 0
ide-tape 34864 0
ide-cd 40548 0
cdrom 37184 2 sr_mod,ide-cd
floppy 59444 0
nls_cp850 4736 4
vfat 13760 4
fat 45120 1 vfat
nls_iso8859-15 4480 6
ntfs 85932 2
supermount 37876 3
amd-k7-agp 7564 1
agpgart 31016 2 amd-k7-agp
ohci-hcd 18692 0
usbcore 99132 4 hid,ohci-hcd
rtc 11576 0
ext3 111048 2
jbd 54680 1 ext3

Mi sembra ci sia un ohci... :master:
Perch non lo carica? Non quello di cui ha bisogno?

Ho provato lo stesso a dare un startmodem; non si sa mai, magari funziona lo stesso...
Al primo tentativo

[root@localhost mappo]# startmodem

setting up USB support (1/5)..
/usr/local/bin/startmodem: line 168: lspci: command not found
/usr/local/bin/startmodem: line 211: lspci: command not found

loading firmware (2/5)..

modem not found

Ho staccato il cavo del modem, l'ho riattaccato e ho riprovato
[root@localhost mappo]# startmodem

setting up USB support (1/5)..
/usr/local/bin/startmodem: line 168: lspci: command not found
/usr/local/bin/startmodem: line 211: lspci: command not found

loading firmware (2/5)..

GlobeSpan USB ADSL WAN Modem compatible modem found (in 2095ms)
ECI load 1: success
firmware loaded successfully

setting up modem (3/5)..

ECI load 2: timeout
failed to get synchronization


In definitiva, un problema di file synch (quindi li provo tutti fino a che non funziona) o un problema del modulo ohci?
Nel secondo caso non so cosa fare. :bh:
Grazie

alex86
29-10-2004, 17:57
prova a caricare il modulo uhcd-hci

modprobe uhci-hcd

poi prova qualche altro file di synch..x il tuo ce ne sono diversi

synch03.bin
synch01.bin
synch02.bin

prova magari a non scollegare il modem dopo una prima tentata connessione e ridai startmodem

:ciauz:

andy caps
29-10-2004, 20:05
installa anche pciutils
lspci dovrebbe essere compreso in quel pacchetto

Mappo
29-10-2004, 22:15
Domani provo e vi so dire.
Speriamo si risolva.
Intanto grazie.

andy caps
29-10-2004, 22:30
se metti la mandrake 10.1 comunque potrebbe essere poi semplice installarli

il kernel della 10.1 dobrebbe avere quelle patch apposite per i modem usb
la trovi anche in edicola

Akiro
30-10-2004, 01:08
ke provider usi?
io con libero adsl uso il synch numero 7
inoltre con il nuovo kernerl l'eci-doctor.sh non affidabile


WARNING! The "eci-doctor.sh" script DOESN'T work with 2.6 kernels, please use only "startmodem".

ricordati che quando devi un-pluggare il cavetto usb devi attendere almeno 4,5 secondi prima di reinserir il cavo

ciau

Mappo
30-10-2004, 21:28
Anch'io ho libero ma il synch 7 non mi funziona.
A dire il vero oggi non ho avuto molto tempo, ho installato pciutils, caricato il modulo uhcd-hci e provato qualche synch (quelli che secondo probe_synch.sh dovevano funzionare). Ovviamente nessun miglioramento. :cry:
Spero di avere un p di tempo in pi per provare tutti i synch e in caso per scaricare la MDK 10.1.
Mi conviene scaricare tutte le iso o basta la prima?
Ciao :ciauz:

andy caps
30-10-2004, 21:49
con la prima si installa tutto il sistema

non so manca pppd
al limite scarica i primi due

Akiro
02-11-2004, 10:48
Originariamente inviato da Mappo
Anch'io ho libero ma il synch 7 non mi funziona.

allora non ti rimane che provar tutti e 51 i synch disponibili :fagiano:



edit: per curiosit, potresti incollare l'output del synch 7?

Andrezinho
02-11-2004, 13:41
boh, io con mandrake (dalla 9) e con lo stesso identico modem non ho mai avuto problemi..

il modulo che uso si chiama eagle-usb, e lo trovi o sui vari mirror in rete oppure nel quarto cd di installazione.

Loading