PDA

Visualizza la versione completa : Installare lili o grub fuori procedura


kar
29-10-2004, 21:43
Salve a tutti.
Ho questo problema da risolvere :
ho installato la knoppix 3.3 sul mio secondo hd (sul primo c'e' win xp), ma nonostante abbia installato lilo quando riavvio mi parte direttamente win xp senza possibilita' di scelta.
Ora volevo sapere : c'e un modo per installare un booloader che mi permetta di scegliere quale s.o. far partire ? O devo reinstallare tutto linux ?
Grazie

Le0n
29-10-2004, 22:26
dove hai installato lilo?? MBR??
hai editato lilo.conf??
in questo file hai messo un delay in modo da avere la finestra di lilo per la scelta??

Hasta!

Caleb
29-10-2004, 22:35
parti col cd live di knoppix ed entra in shell come root:

mkdir /mnt/linux
mount /dev/hdXY /mnt/linux
chroot /mnt/linux


(sostituisci XY con la lettera e il numero della partizione su cui hai installato linux)
ora sei nel sistema installato:

cat /etc/lilo.conf

poi torna qui e posta il contenuto di lilo.conf

kar
29-10-2004, 23:38
dunque : il comando mount /dev/hdd7 /mnt/linux mi da questo errore :
mount :/dev/hdd7 gia' montato o /mnt/hdd7 /mnt/linux occupato
e cosi' pure il comando chroot /mnt/linux risponre : no souch file.
Comunque il cat mi da questie linee (escludendo le remmate) :
- lba32
- boot=/dev/hda
- install=/boot/boot-menu.b
- backup=/dev/null
- map=/boot/map
- timeout=100
- vga=normal
- default=knoppix
- image=/vmlinuz append"lang=de apm=power-off
hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi vga 791 quiet
- boot_image = knoppix "root=/dev/hda5 label=knoppix read-write"

Aspetto istruzioni (dettagliate), grazie.
Ciao, Carmelo.

Le0n
29-10-2004, 23:42
io metterei prima del timout un delay=50 e un prompt...

per info man lilo.conf...

vorrei inserire qualche altra info ma ora non ho linux e non ti saprei dire....


hasta!

maiosyet
29-10-2004, 23:44
Originariamente inviato da kar
dunque : il comando mount /dev/hdd7 /mnt/linux mi da questo errore :
mount :/dev/hdd7 gia' montato o /mnt/hdd7 /mnt/linux occupato
e cosi' pure il comando chroot /mnt/linux risponre : no souch file.


Knoppix monta in automatico le partizioni che trova...forse Caleb non lo sapeva, non ti preoccupare normale :)



Comunque il cat mi da questie linee (escludendo le remmate) :
- lba32
- boot=/dev/hda
- install=/boot/boot-menu.b
- backup=/dev/null
- map=/boot/map
- timeout=100
- vga=normal
- default=knoppix
- image=/vmlinuz append"lang=de apm=power-off
hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi vga 791 quiet
- boot_image = knoppix "root=/dev/hda5 label=knoppix read-write"


Vedi dove viene montata la partizione di Linux, fai il chroot come detto da caleb e digita

lilo - v

Caleb
30-10-2004, 00:26
ops mi ero scordato dell'automount

pero' e' strano, nel suo lilo.conf e' gia' specificato l'mbr di hda, chissa' perche' non gliel'ha installato? in compenso non vedo nessuna sezione per avviare win

Caleb
30-10-2004, 00:30
ahia... non avendo nessuna sezione che avvia win come ci ritorna sul forum a chiedere aiuto dopo aver aggiornato il bootloader? si spera che knoppix gli abbia sistemato la rete...

kar
30-10-2004, 00:43
beh, io fino a quando mi date risposte CERTE non modifico nulla !!!
Nel frattempo, questa notte, scarichero' sia la suse 9.2 live cd che la knoppix 3.6
Sapete se anche la suse si puo' poi installarla su hd ?
Grazie
Ciao

Caleb
30-10-2004, 00:49
uh eccoti sano e salvo... ehm temevo per la tua sorte

il fatto e' che il tuo lilo.conf e' strano: manca tutta la parte relativa a windows, come minimo dovresti avere questa parte in piu':

other=/dev/hdXY
table=/dev/hdX
label=Windows

sostituendo a XY lettera e numero della partizione appropriata... ma hai gia' provato a escludere dal bios il primo hd con windows in modo da vedere se parte linux? sempre che ci sia un bootloader sul secondo hd...

Loading