PDA

Visualizza la versione completa : MDK 9.1 ed urpmi


peziza
30-10-2004, 18:00
Ciao,

Vorrei aggiornare la mia MDK 9.1, ma su easy urpmi non riesco a trovare la voce "updates" e dei server che funzionino bene. Quando poi faccio urpmi --auto-select ad un certo punto mi dice che molti files hanno firme errate e non me li installa nonostante gli dica di proseguire.

Qualcuno ha qualche elenco di server funzionanti ?

Come devo fare per far installare ugualmente i pacchetti con le firme errate ?

Lo cercherei sul forum ma la ricerca non va ...

Grazie

andy caps
30-10-2004, 18:20
http://easyurpmi.zarb.org/index.php?user%5Bvers%5D=9.1&user%5Barch%5D=i586&selection%5Bcontrib%5D=on&mirror%5Bcontrib%5D=ftp%3A%2F%2Fbo.mirror.garr.it&selection%5Bmain%5D=on&mirror%5Bmain%5D=ftp%3A%2F%2Fbo.mirror.garr.it&selection%5Bupdates%5D=on&mirror%5Bupdates%5D=ftp%3A%2F%2Fbo.mirror.garr.it&selection%5Bplf%5D=on&mirror%5Bplf%5D=ftp%3A%2F%2Fspirit.bentel.sk&selection%5Bclub%5D=on&mirror%5Bclub%5D=ftp%3A%2F%2Fftp-stud.fht-esslingen.de&selection%5Bjpackage.free%5D=on&mirror%5Bjpackage.free%5D=ftp%3A%2F%2Fftp.pbone.ne t&prefix=#third

questi dovrebbero andare

per testarli puoi anche selezionare la casella sopra alle stringhe per scaricarle in forma compressa senza le info (pochi kb )

la gpg dovrebbe scaricarla al momento che scarica le immagini e non dovrebbe chiederla

gia che aggiorni potresti agiornare all'ultima versione di mandrake (la 10.1 final ) dalla 9.1 possibile
credo lo abbia fatto akiro ultimamente

peziza
30-10-2004, 18:26
grazie, adesso provo, poi magari prover ad aggiornare alla 10.1

mykol
31-10-2004, 10:04
riattivo questo thread per non aprirne un ennesimo simile ...

Anch'io ho cercato di aggiornare la mia MDK 9.1 (voglio vedere se ci riesco e poi magari la upgrado a 10.1) usando i server che tu, andy, hai suggerito sopra a peziza.

Ad un certo punto, dopo aver aggiornato parecchia roba, ma ad un certo punto mi dice che una sfilza di pacchetti hanno la firma errata. Lo faccio continuare ugualmente dandogli si, ma subito mi da il seguente errore:

perl-URPM >= 0.94 richiesto da urpmi-4.4.5-3mdk

ho provato a cambiare server, ecc... ma nulla, si blocca sempre a quel punto. Come posso risolvere ?

Ancora, (in generale, non solo in questo caso ...) esiste un modo per superare il prob delle firme ? Anche se gli dico si si ferma ugualmente e l'aggiornamento non prosegue.

Grazie

andy caps
31-10-2004, 10:19
se non trova perl-URPM non puo proseguire l'aggiornamento perche ti troveresti un sistema inutilizzabile

se manca sui server non possibile aggiornare

prova a cambiare server


mi sembra strano che ti voglia installare urpmi-4.4.5-3mdk
sui quei server c' File: urpmi-4.2-33mdk.noarch.rpm

:master: se hai messo altre repository particolari toglile

andy caps
31-10-2004, 10:25
ho trovato il problema

devi togliere le repository del club perche' hanno messo li urpmi-4.4.5-3mdk e crea tutto il pasticcio

:bh: strano che abbiano fatto un pasticcio del genere

sullle repository del club comunque non c' moltissimo

ftp://bo.mirror.garr.it/mirrors/Mandrake/devel/testing/Mandrakeclub/9.1/noarch/

mykol
31-10-2004, 10:28
Grazie ancora, pi tardi provo. Ora devo uscire. Qualche volta bisogna anche ricordarsi della famiglia ...

andy caps
31-10-2004, 10:37
comunque utilizzando un altro server troverebbe anche perl_URPM della versione corretta

ho corretto i link sopra

prova questo server per il club che contiene molto sofware in piu' lo puoi anche semplicemente aggiungere come club2 come ti ho correto

urpmi.addmedia club2 ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/Mandrakelinux/devel/testing/Mandrakeclub/9.1 with hdlist.cz

mykol
31-10-2004, 20:38
ho tolto il club ed ho rifatto urpmi --auto-select ed ha funzionato. Ho solo dovuto disinstallare i win32-codecs (mi pare, se ricordo bene win32-codecs-5.0). L'ho fatto ed andato tutto a buon fine e mi ha installato altri win32-codecs.

Dopo provo a mettere club2 ed a ripetere urpmi --auto-select.

Ancora una domanda: sto aggiornando anche kde (sempre alla 3.1) e mi sta installando tutta una serie di locales che non mi interessano, tipo af, ar, az, fr, (ma nell'elenco non c' it)....... Se poi li disinstallo posso avere problemi ?

Ancora grazie

Loading