PDA

Visualizza la versione completa : [debian woody] ext2 -> ext3


martex
05-11-2004, 22:21
Ho notato che installando una woody, non c'Ŕ possibilitÓ di avere un ext3, volevo sapere che devo fare, a parte ricompilare il kernel per cambiare il filesystem della mia partizione debian?

andy caps
05-11-2004, 22:36
installando woody puoi formattare le partizione come credi

dopo avere creato la partizione in ext2 con l'installazione (cfdisk) al momento di scegliere le partizioni puoi scegliere anche il filesystem

devi solo dogitare al boot: dell'installazione
bf24 cosi ti mette il kernel 2.4.18
puoi mettere sia ext3 che reiserfs

wittgen105
05-11-2004, 22:38
Originariamente inviato da martex
Ho notato che installando una woody, non c'Ŕ possibilitÓ di avere un ext3, volevo sapere che devo fare, a parte ricompilare il kernel per cambiare il filesystem della mia partizione debian?
Hai selezionato da fdisk il formato ext3???

martex
05-11-2004, 22:42
...quindi, dovrei reinstallarla dando l'opzione al boot per il kernel 2.4?

E per quanto riguarda i moduli per l'usb, ho un manta e vorrei upgradarla tramite apt-get, come posso dirla che voglio quei moduli, con il kernel 2.22 non me li ha inseriti!

andy caps
05-11-2004, 22:44
il kernel 2.4 ha anche il supporto per le usb
conviene reinstallarla altrimenti compilare il kernel

martex
06-11-2004, 03:19
WOW!!! Finalmente ci sono riuscito, orsa sto scrivendo con una Debian con wmake, l'unico dubbio che mi rimane Ŕ come mai quando seleziono un pacchetto mi trova un sacco di dipendenze!

Infatti, ho provato ad installare mozilla-firefox ma mi trova una marea di dipendenze e alla fine mi dice "broken pakage", ora sto scrivendo con lynx!!!

Caleb
06-11-2004, 03:33
per qualsiasi distro il comando per convertire da ext2 a ext3 preservando i dati e'

tune2fs -j /dev/hdXY

dove XY sono unita' e numero della partizione, l'ext3 non e' altro che un ext2 col journaling; poi occorre aggiornare /etc/fstab di conseguenza indicando ext3 al posto di ext2, e ovviamente devi avere il supporto nel kernel

e' normale che ti trovi delle dipendenze, con apt-get install mozilla-firefox ti tira giu' tutto il necessario purche' in /etc/apt/source.list tu abbia inserito i repository corretti

quale pacchetto in particolare ti viene segnalato come rotto?

Ikitt
06-11-2004, 09:53
Originariamente inviato da wittgen105
Hai selezionato da fdisk il formato ext3???
E` lo stesso di ext2 (0x83, linux native)

martex
06-11-2004, 10:28
le dipendenze che mi da sono: mozilla-firefox: Depends: libgtk2.0-0 (>= 2.4.4) but it is not going to be installed
Depends: libpango1.0-0 (>= 1.4.1) but it is not going to be installed
Depends: libxft2 (> 2.1.1) but it is not going to be installed
Depends: libxrender1 but it is not going to be installed
E: Sorry, broken packages

per quanto riguarda i repository nella source.list sono quelli indicate dalla distro al momento dell'installazione!!!

andy caps
06-11-2004, 11:04
se hai installato la woody in genere mette solo il cdrom come sources.list

dai un apt-setup per aggiungere una repository poi se vuoi passaree a sarge o sid devi modificare /etc/atp/sources.list scrivendo testing o unstable al posto di stable

Loading