PDA

Visualizza la versione completa : [slack] erorre scrittura LILO sia su MBR, su floppy e root... e altri errori


staza
10-11-2004, 00:34
ciao,
ho avuto problemi nel installare LILO sul MBR a fine installazione.... nonch ho avuto problemi nel settare la passeword di root (mi dice che il file password is lock o una cosa del genere)...

premetto che ho gi cercato in rete ma non ho trovato nulla, ho riprovato 3 volte la reinstallazione con lo stesso risultato, inoltre ho creato il boot floppy, ma pure questo non va... parte il boot da floppy e poi nn lancia la partizione in cui installata la "/"

L'HD non credo che sia difettoso, prima avevo installato la slack 10, ma dopo cambio scheda madre e processore e scheda video, ho proceduto con la reinstallazione del sistema operativo...ma ho riscontrato questi problemi... ho provato a cercare anche nel bios se vi erano opzioni di protezione del MBR o qualcosa che richiamasse l'MBR ma non ho trovato nulla

scheda madre K7S5A
amd duron 1800
sch vido geforce 4 64MB

queste quello che ho cambiato

spero mi sappiate aiutare

grazie

ho provato a montare tutto in /mnt e provato a fare il chroot (usando il primo cd di slack)

mount /dev/hda1 /mnt
mount /dev/hda7 /mnt/home
e cos via

poi ho dato chroot /mnt ma da l'erore:

/bin/sh: error while loading shared libraries: /lib/libtermcap.so.2: file too short


********************

l'errore che da con lilo o con la configurazione della rete :

can't open /sbin/config

o una cosa simile

Sergio Pedone
10-11-2004, 00:48
Ciao.
Premetto che non so se potro esserti d'aiuto, ma volevo capire
un paio di cosette:
- come mai dopo il cambio di hardware hai voluto reinstallare
il sistema operativo? Avevi un kernel specifico per il vecchio
hardware?
- Non che il supporto ottico ha qualche problemino e non
possibile installare alcune parti del sistema, quali librerie
e lilo, liloconfig, ecc.?

:)

staza
10-11-2004, 14:21
ho voluto reinstallare il tutto per avere una distribuzione pi pulita... la prima era di prova (infatti avevo programmi che nonutilizzavo altri si etc etc)

il lettore va bene (infatti prima ho reinstallato win

a sto punto che non sia il cd rovinato?

ma mi sembra alquanto strano...

sabato provo a ricrearmi un cd (uso un rw) col primo cd di slack

se aveta altre idee...sono qui :D

Sergio Pedone
10-11-2004, 19:25
Originariamente inviato da staza
a sto punto che non sia il cd rovinato?

Io intendevo proprio questo...

staza
10-11-2004, 20:36
allora, ho provveduto a rimasterizzarmi il primo cd della distro...

reinstallato...

risultato: niente di niente..soliti errori

mi da anche come errore, alla fine dell'installazione quando creo la pswd per root mi dice che "can lock file pswd, try later" o una cosa del genere...sul try later sono sicuro.... ma sono le solite cose che dicono :) o provato later ma nulla..

non so pi dove sbattere la testa... :dh: :dh:

una cosa, da bios ho attivato la SMART per gli HD...potrebbe centrare quest "utility" con il fatto che ho sti problemi?

Loading