PDA

Visualizza la versione completa : mandrake e modem ethernet - configurazione per alice


Andrezinho
12-11-2004, 02:29
ciao ragazzi!
scusate se chiedo su argomenti magari già discussi, ma ora capirete il perchè:

stamattina mi sono finalmente deciso di sbarazzarmi del modem adsl usb (il nd220) che mi aveva dato in comodato la telecom con Alice, ed ho preso un aethra eb1070, quello con uscita sia ethernet che usb, per intenderci.

non ho avuto grossi problemi nel configurarlo, ma ora il problema è che la navigazione è lentissima, per caricare google mi ci vogliono tipo 30 secondi.. non parliamo poi di entrare su questo forum, mi ci è voluto un secolo.

Ora vi mostro come ho proceduto alla configurazione, così magari mi sapete dire se ho sbagliato qualcosa, chessò nei DNS.. (visto che non è la banda a mancarmi: scarico tranquillamente ad 80 kps, anche con questa connessione)

dunque:
nuova connessione -> adsl
interfaccia di rete: la mia scheda di rete
protocollo: ppp over ethernet
nome del provider: tin.it
primo server dns: 212.216.112.112
secondo server dns: 212.216.172.62
login dell'accoun:
password:

oky, mi si connette a colpo, ma il problema resta.

sotto "gestisci connessioni" mi indica 2 connessioni:
adsl ed eth0

sotto adsl trovo:
tcp/ip:
indirizzo ip: nessun ip
netmask: nessuna maschera
i server dns : tre server dns che non centrano una mazza con quelli che gli ho dato io (195.31.14.211, .........)
dominio di ricerca: it (mentre io gli avevo dato "alice"

sotto la connessione "eth0":

tcp/ip: dhcp
attiva al momento del boot attivato
hotplugging della rete attivato

cerco di modificare a mano il file /etc/resolv.conf,
ma ad ogni nuova connessione ad internet me lo modifica inserendo i suoi parametri, presumo lo faccia col DHCP

vi listo anche l'output di ifconfig, magari scoprite qualcosa:

eth0 Link encap:Ethernet HWaddr 00:0E:A6:C4:7B:68
inet6 addr: fe80::20e:a6ff:fec4:7b68/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17 Memory:fde00000-0



lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:42 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2656 (2.5 Kb) TX bytes:2656 (2.5 Kb)



ppp0 Link encap:Point-to-Point Protocol
inet addr:80.180.138.162 P-t-P:192.168.100.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:1454 errors:0 dropped:0 overruns:0 frame:0
TX packets:1862 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:594528 (580.5 Kb) TX bytes:196860 (192.2 Kb)

grazie a chiunque abbia voglia di darmi una mano

ciao!

Andrezinho
12-11-2004, 02:51
ho fatto un passo avanti, non chiedetemi come =_=

è un problema di dns (ma forse fino a qui c'eravamo anche arrivati)

ad oggni avvio , mi mette i suoi dns, che non vanno per niente bene, infatti i tempi di attesa sono notevoli (come prima)

ora però, sostituendo in resolv.conf i suoi "dns" con i "miei" (o meglio, quelli che mi ero segnato dalla configurazione con l'altro modem) mi va alla giusta velocità.

ora il problema è che ad ogni riavvio, mi torna a mettere i "suoi" dns, sovrascrivendo /etc/resolv.conf

cosa potrebbe fargli fare una cosa simile, visto che ho anche disattivato il dhcp?

Caleb
12-11-2004, 03:54
lasciami indovinare: debian

non ho ancora capito cos'è che sovrascrive il resolv.conf, comunque come palliativo puoi sfruttare if-up, uno script che quando la connessione sale esegue tutto quello che si trova in etc/network/if-up.d/

crea uno script in quella directory, mettici dentro sta roba (ovviamente inserendo i dns corretti) e dagli i permessi di esecuzione:



#!/bin/sh

echo "nameserver w.x.y.z" > /etc/resolv.conf
echo "nameserver w.x.y.z" >> /etc/resolv.conf



in questo modo quando ti sale la connessione ti inserisce automaticamente in resolv.conf i tuoi dns, indipendentemente da cosa è stato inserito al boot... quanto alla sovrascrittura mi premurerò di indagare quanto prima

Andrezinho
12-11-2004, 11:50
sbagliato :D :D :D non è debian, ma mandrake, anche se alla debian, ora che posso farci girare l'adsl senza diventare matto con il modem usb, ci stavo facendo un pensierino

Grazie mille per la risposta, appena risolvo qualcosa vi faccio sapere


ciao ciao

Andre

Andrezinho
12-11-2004, 12:22
beh, non ho risolto niente, ma vi faccio sapere lo stesso, magari ho fatto qualche stupido errore...

la cartella "if-up.d" in mandrake si trova sotto /etc/sysconfig/network-scripts.

all'interno di questa cartella, ci metto lo scriptino suggerito, pari pari, e lo nomino if-up, tanto per essere originali.

gli fo un chmod in modo che possa essere eseguibile.

ma ahimè non funzica!!

Andrezinho
12-11-2004, 12:56
risolto!

ho scoperto cos'era che mi sovrascriveva i dns:

in /etc/ppp c'è il file pppoe.conf, con le varie opzioni per l'adsl.

Voci presenti:

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.

prima: DNSTYPE=SERVER
dopo: DNSTYPE=SPECIFY

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS. Changed to
# PEERDNS for better Red Hat compatibility
prima: PEERDNS=yes
dopo: PEERDNS=no

prima: DNS assolutamente farlocchi
dopo: DNS1=212.216.112.112
DNS2=195.31.14.211

ora alla connessione ma mantiene le impostazioni di questo file anche in resolv.conf

yessssssssssssssssss

ciao ciao!

asiul
12-11-2004, 14:52
Originariamente inviato da Andrezinho
ciao ragazzi!
scusate se chiedo su argomenti magari già discussi, ma ora capirete il perchè:

stamattina mi sono finalmente deciso di sbarazzarmi del modem adsl usb (il nd220) che mi aveva dato in comodato la telecom con Alice, ed ho preso un aethra eb1070, quello con uscita sia ethernet che usb, per intenderci.


Scusa se divago un po', ma te lo sei fatto cambiare da loro oppure quello usb glielo hai solo restituito e quello ethernet lo hai comprato?
A me hanno chiesto 20 euro per fare il cambio di modem e poi continuare lo stesso a pagare l'affitto mensile! :jam:

Andrezinho
12-11-2004, 15:46
ho telefonato al 187, e (caso piu unico che raro) ho trovato un'operatrice gentilissima che mi ha spiegato tutto per bene)

avevo queste possibilità:

-fingere di avere il modem rotto, e farmelo cambiare gratis con un altro a mia scelta da un corriere che me l'avrebbe portato a casa

-chiedere semplicemente la sostituzione, pagando 18 euro per la consegna

-farmelo cambiare (sempre in comodato) ad un punto 187, senza spese.

Andato al punto 187 però mi dicono che le cose non stanno così, che loro non cambiano il modem in comodato, ma che se voglio posso comprare uno dei loro modem, dando indietro il mio e terminando così il noleggio.

Ora non so se il fatto che non lo possano cambiare è vero, fatto sta che mi sono comprato il modem nuovo, da loro (40 euro), sopratutto per evitarmi la trafila di dover farmi togliere l'addebito del noleggio tramite gli operatori del 187, lasciando questo onere a quelli del negozio.

eraclito
12-11-2004, 17:19
controlla la prossima bolletta...

io ho impiegato tre bollette (6 mesi) e 150 telefonate per farmi togliere il canone di un telefono che non avevo mai avuto...

asiul
12-11-2004, 20:08
Originariamente inviato da Andrezinho
ho telefonato al 187, e (caso piu unico che raro) ho trovato un'operatrice gentilissima che mi ha spiegato tutto per bene)

avevo queste possibilità:

-fingere di avere il modem rotto, e farmelo cambiare gratis con un altro a mia scelta da un corriere che me l'avrebbe portato a casa

-chiedere semplicemente la sostituzione, pagando 18 euro per la consegna

-farmelo cambiare (sempre in comodato) ad un punto 187, senza spese.

Andato al punto 187 però mi dicono che le cose non stanno così, che loro non cambiano il modem in comodato, ma che se voglio posso comprare uno dei loro modem, dando indietro il mio e terminando così il noleggio.

Ora non so se il fatto che non lo possano cambiare è vero, fatto sta che mi sono comprato il modem nuovo, da loro (40 euro), sopratutto per evitarmi la trafila di dover farmi togliere l'addebito del noleggio tramite gli operatori del 187, lasciando questo onere a quelli del negozio.

Questa è un'odissea!
Anche io ho telefonato al 187 e ho parlato con un operatore abbastanza sbrigativo, che mi ha detto che dovevo pagare 20 euro (a me 20 e a te 18?) e venivano a prendermi quello vecchio e portarmi quello nuovo.
Poi qui ho letto che qualcuno è andato al punto 187 e l'ha cambiato lì, quindi mi sono fermata ad un punto 187. Lì mi hanno detto che le cose non stanno così! Loro non me lo cambiano, devo fare tutto io tramite telefono, e sanno che più o meno il modem mi arriva via corriere e quello da mandare indietro devo spedirlo come raccomandata!
E' troppo difficile mettersi d'accordo?
E se fingo che mi si sia rotto? Suppongo che se telefono al 187 loro mi faranno fare delle prove insieme ai loro "tecnici" per vedere se è davvero rotto, no? E se anche riuscissi a fingere bene e poi scoprono che non era rotto? :master:
Una mia amica ha tranciato il filo che dal modem va alla presa del telefono (lei per sbaglio) e glielo hanno cambiato....potrei fare così anche io! :confused:
Ora il problema è valutare se mi conviene di più comprarlo o continuare a pagare l'affitto alla telecom! :jam:
Penso che mi rifarò viva ben presto su questo forum!
Ma se il motore di ricerca funzionasse io potrei cercarmi post che mi interessano, no?!!?!? :jam:

Loading