PDA

Visualizza la versione completa : mandrake e fedora - boot da lilo


Andrezinho
14-11-2004, 23:35
saluti a tutti!

ho appena installato Fedora 3

avendo su mandrake, ho scelto di lasciare lilo come bootloader, aggiungendogli la voce relativa a Fedora

Il problema che al boot di fedora, al momento di montare la partizione root, mi d:

VFS: cannot open root device ........ or unknown bloc(33,12)
Please append a correct "root=" boot option
kernel panic - not syncing: vfs: unable to mount root fs or unknown block

presumo che questo significhi che su lilo, alla voce di fedora, devo specificare sotto "append" la partizione di root, ma questo l'ho gi fatto, e gli esiti sono gli stessi.

Vi posto il lilo.conf


image=/boot/vmlinuz
label="mandrake"
root=/dev/hde13
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hde5 splash=silent"
vga=788
read-only

other=/dev/hdf1
label="windows"
table=/dev/hdf
map-drive=0x80
to=0x81
map-drive=0x81
to=0x80

image=/boot/vmlinuz-2.6.9-1.667 (il file l'ho copiato nella directory /boot di mandrake)
label="fedora"
append="root=hd0,11"


schema delle partizioni:

/dev/hde1 -> /boot (creata per mandrake)
/dev/hde13 -> / di mandrake
/dev/hde12 -> / di fedora


il bootloader installato nella mbr di hde

cosa sbaglio? qualcuno puo' aiutarmi?

grasssssssie

Andre

andy caps
14-11-2004, 23:39
append="root=hd0,11"

prova al posto di questo a mettere

root=/dev/hde12

Andrezinho
14-11-2004, 23:42
ahim, la prima che ho fatto, ma nemmeno partiva :(

ho provato una soluzione "grezza", installando il grub su hde12 e poi facendolo partire da lilo, ma non va

devo fargli capire dove sta la root, ma non so in che altro modo :dh:

andy caps
14-11-2004, 23:45
se hai messo grub di fedora nella sua partizione di root dovrebbe bastare

other=/dev/hde12
label=fedora

Andrezinho
14-11-2004, 23:47
infatti, la soluzione "grezza" di cui ti stavo parlando, ma che nemmeno mi partiva (schermata nera fissa)

Andrezinho
15-11-2004, 00:02
ce l'ho (quasi) fatta!

sbagliavo l'append, dovevo mettere append="root=LABEL=/"
xche ho visto sull'fstab di fedora che la root era segnata cos (non ho la minima idea del perch)

ora mi va in blocco all'avvio di X, beh, ma questo un'altro discorso

grazie!

ANdrea

andy caps
15-11-2004, 00:08
:confused: mah
non avevo mai visto un impostazione simile di lilo

Andrezinho
15-11-2004, 00:17
l'ho trovato qui, e dopo aver controllato l'fstab, l'ho copiato :bh:

http://www.europe.redhat.com/documentation/rhl8.0/rhl-cg-it-8.0/s1-custom-kernel-bootloader.php3

se non chiedo troppo , sapete dirmi qualcosa sul "freeze" all'avvio di X?

posto un paio di righe del log di che mi sembrano interessanti:

Nov 14 22:58:48 localhost kernel: agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
Nov 14 22:58:48 localhost kernel: agpgart: Badness. Don't know which AGP mode to set. [cmd:1f000a0a tmp:1f000a1a fell back to:- cmd:1f000a08 tmp:1f000a1a]
Nov 14 22:58:48 localhost kernel: agpgart: Bridge couldn't do AGP x4.
Nov 14 22:58:48 localhost kernel: agpgart: Graphic card couldn't do AGP x4.
Nov 14 22:58:48 localhost kernel: agpgart: Badness. Don't know which AGP mode to set. [cmd:1f000a08 tmp:ff00021b fell back to:- cmd:1f000208 tmp:ff00021b]
Nov 14 22:58:48 localhost kernel: agpgart: Bridge couldn't do AGP x4.
Nov 14 22:58:48 localhost kernel: agpgart: Putting AGP V3 device at 0000:00:00.0 into 0x mode
Nov 14 22:58:48 localhost kernel: agpgart: Putting AGP V3 device at 0000:01:00.0 into 0x mode

potrebbe essere questo il problema?

francofait
15-11-2004, 00:27
No il problema reale che continui a dimenticarti di inserire

initrd = /boot/initrd........img

non pu essere omesso , e devi farne una copia in /boot di mdrake come hai fatto x il kernel altrimenti non lo trova e continua a dari ' kernel panic ' x forza

In append oltre root = .... aggiungi anche acpi=on apm=off no apic

altrimenti acpi ed apm in fedora x default risultano entrambe attivi e vanno in conflitto , bloccando il sistema prima della fine della fase di avvio.

andy caps
15-11-2004, 00:30
potrebbe essere

ma se fedora faceva il boot regolarmente non si capisce perche debba fare questo


prova se gli piace a mettere una riga in xorg.conf

Option "AGPMode" "4"

magari metti 1 al posto di 4

Loading