PDA

Visualizza la versione completa : sovraccarico della cpu causa malfunzionamento della rete


adarkar
15-11-2004, 00:23
salve a tutti!

questo problema mi si era già presentato e non avevo trovato nessuna soluzione ma siccome continua a infastidirmi ci riprovo.. magari qualcuno ha/ha avuto esperienze simili

in poche parole ho constatato che quando la cpu è un po' caricata, anche un 70% è abbastanza, ma più sale e peggio è, la rete impazzisce, o meglio non funziona più
quel che si avverte è l'impossibilità di stabilire una connessione con un qualunque host

la cosa diventa ancora più fastidiosa quando a dovermi connettere non sono io da questo pc ma qualcuno da un altro pc della rete, che essendo routato da questo non riesce neanche lui a connettersi

per fare un esempio del carico della cpu: 70% usr, 2% sys e le connessioni funzionano circa una volta su 2/3, se la cpu va a 80/90% le connessioni hanno successo anche una sola volta su una decina di tentativi

data la mia eterna niubbità la sola cosa che sono riuscito a pensare è quell'opzione "preemptible kernel" che trovo nella conf del mio 2.6.8, opzione che al momento non uso soprattutto per il semplice fatto che dà problemi coi driver nvidia

dato che la rete è controllata dal kernel io ho fatto la pensata che la colpa possa essere là, voi che dite?

OS:
gentoo 2004.1
cflag usate = -O2 -march=pentium4
kernel 2.6.8 gentoo
cflag usate per il kernel = nessuna (con -march=pentium4 era peggio di adesso.. sì ho un p4!)
gcc 3.3.4

wittgen105
15-11-2004, 00:28
Potrebbe essere, comunque se hai a disposizione un'altra scheda di rete non nvidia prova a montarla e a ricompilare il kernel abilitando quell'opzione.
Lo so è un po' fastidioso ma in questo modo potresti anche risolver il to dubbio. :D

Comunque, la mia è solo un'ipotesi non ne sono sicuro. :bhò:

adarkar
15-11-2004, 00:33
uhm nono la eth è via e funziona bene bene, nvidia è la geforce e si impalla se metto il preemptible kernel

c'è da dire che potrei anche fare un test caricando la cpu e provando a connettermi il tutto senza usare X con driver nvidia.. però volevo sapere se qualcuno ha idee su quale possa essere la causa di questa rottura :stordita:

Loading