PDA

Visualizza la versione completa : installazione driver modem 56k pci


7r0i0n3
16-11-2004, 20:07
:dh: :dh: sono nella cacca, bella premessa non pensate?
penso di essere uno dei pochi fortunati a possedere un modem munito di driver per linux, il problema che non riesco ad installarli, come si fa??
se seguo il read me, non concludo niente, mi dice che sbaglio directory dove si trova modversions.h se cambio la destinazione in MAKEFILE, no risolvo niente ugulamente, spero che qualcuno di voi riesca ad aiutarmi cos disinstallo XP che mi ha vivamente rotto le scatole, il modem uno smartlink 56k voice modem pci. :dh:

7r0i0n3
16-11-2004, 20:20
n.b.

prima di aprire una nuova discussione mi sono spezzato gli occhi in giro su forum e web e non ho trovato nulla di dettagliato e utile,
premetto che sono realmente messo male per quanto riguarda linux.

ringrazio anticipatamente

Meskalamdug
16-11-2004, 20:23
Magari specificando il tipo di modem potremmo anche darti una mano...

7r0i0n3
16-11-2004, 20:24
smartlink 56k voice modem pci

Dario89
16-11-2004, 22:27
che kernel hai?
se hai il 2.6.* il rpoblema che quei driver sono per il 2.4 (c' anche scritto nel README: "OS: Linux 2.4 series.")

scarica dal sito smartlink gli ultimi (io ho i 2.9.10) o comunque una release compatibile con il 2.6 e usa quelli

$make
#make install
#modprobe slamr
#slmodemd --country=ITALY /dev/ttySL0

e, se usi kppp che vuole /dev /modemm, crei il collegamento
#ln /dev/ttySL0 /dev/modem -s
#kppp

se usi wvdial devi aggiungerre al wvdial.conf da qualche parte in /etc/ la riga
Carrier Check = no

poi ti crei in $HOME/.kde/Autostart
uno script tipo questo

#script per modem fatto da me
#se usi la mandrake /script/mandrake, se debian /script/debian e cos via..
cd /home/dario/modem/slmodem-2.9.10/scripts/mandrake
./slmodemd start
#controll di poter usare sudo in /etc/sudoers, se no edita con visudo
sudo slmodemd --country=ITALY /dev/ttySL0
kppp

EDIT
ecco il link
scricatelo!!! (http://www.smlink.com/main/item.php?ln=en&item_id=84&main_id=32)

Loading