PDA

Visualizza la versione completa : ho fatto un casino, "missing operating system"


lexotan
16-11-2004, 21:14
ciao a tutti, vi scrivo con knoppix.
ho installato linex, che utilizza grub, e deve aver cambiato qualcosa che è fuori dalla mia portata per poter rimediare. il risultato è che non parte più windows e nemmeno riesco a reinstallarlo, in quanto esce sempre "missing operating system". questa vale anche senza altre sistemi operativi e nemmeno partizioni. se faccio (mi butto ma non so) cfdisk /dev/hda con knoppix esce questo:
the number of cylinder for this disk isset of 79656
thereis nothing wrong with that, but this is largher then1024 and there are problems withsoftware the runs at boot end booting from other oss

sono quasi certo che sia un problema derivato da grub o comunque che non mi trova il modo di far partire win, che comandi posso utilizzare per capire di più?
ciao

lexotan
17-11-2004, 16:26
up!

:oVVoVe:

datemi almeno un consiglio, cambio hard disk?

bakuryu
17-11-2004, 17:19
entra nel bios, abilita il cd come prima opzione per il boot e inserisci il cd di linux o di windows.

andy caps
17-11-2004, 21:20
al limite de pendi un floppy di win 98 o con un cd di xp e ripulisci l'mbr dovrebbe partire windows regolarmente

fdisk /mbr con il floppy

fixmbr con il cd di xp da consolle di ripristino

lexotan
19-11-2004, 15:10
bakuryu entra nel bios, abilita il cd come prima opzione per il boot e inserisci il cd di linux o di windows.


:dottò:



al limite de pendi un floppy di win 98 o con un cd di xp e ripulisci l'mbr dovrebbe partire windows regolarmente

fdisk /mbr con il floppy

fixmbr con il cd di xp da consolle di ripristino


fatto, grazie, ma è uguale a prima.
mi hanno parlato di una "low formatting"
che ne dite?
si può fare con knoppix?
:(

andy caps
19-11-2004, 15:16
che dischi hai

in genere tutti i costruttori hanno le utility apposta

io ho usato quella della maxtor per risistemare

Darrol
19-11-2004, 19:19
Originariamente inviato da andy caps
che dischi hai

in genere tutti i costruttori hanno le utility apposta

io ho usato quella della maxtor per risistemare

quoto,
io avevo creato un disastro ed i vari s.o. non riuscivano più a trovare il mbr.

Dal sito della maxtor c'è un programmino (Max Blaster) che ti formatta il disco a basso livello.
Penso che funzioni con qualunque tipo di hd, indipendentemente dalla marca.
Occhio che non è la più rapida della operazioni, io per 80 giga ci ho messo 7 ore.

Buon divertimento

bakuryu
19-11-2004, 20:25
Originariamente inviato da lexotan
:dottò:

a me è capitato diverse volte e ho risolto in quella maniera :bhò:

lexotan
20-11-2004, 13:22
ciao
sono depressissimo

ho un maxtor da 40 giga
e ieri ne ho comprato uno da 80, sempre maxtor

farò come dite, provo la formattazione con quello da 40..ma......

il problema qua è che anche in quello nuovo da 80, ho messo per i primi 40 giga winxp, poi per i secondi 40 ho provato nell'ordine:
ubuntu
debian
slack
mandrake

il problema rimane lo stesso,
non si installa il bootloader, che sia lilo o grub
anche con partizionamento automatico


da bios il primo boot è messo come cdrom
il secondo primary master e il l'hard disk è rilevato come primary master (ogni volta ne attacco solo uno)

adesso comincio a pensare che sia partito qualcosa nel bios.
cosa si guarda in questi casi?
grazie mille a tutti

ps.

bakuryu, pensavo fosse una battuta..comunque c'ho provato ma era già impostato così dato che per risolvere questa cosa ho installato 150 volte in due giorni

andy caps
20-11-2004, 13:57
non credo dipenda dal bios altrimenti non andrebbe nemmeno xp
puoi provare a switchare tra chs a lba nel bios
o prova a installare lilo nella partizione di root delle varie distro e installare un booloader esterno che si installa da windows tipo gag o xosl

sei hai un controller sata potrebbe essere non riconosciuto e con gag risolveresti

Loading