PDA

Visualizza la versione completa : Non sento più il suono


Sergej_D
21-11-2004, 13:04
Salve a tutti.
Ho una debian sarge (ho fatto l'upgrade stamattina).
Da qualche giorno non sento più l'audio.
Ho configurato alsa con alsaconf, vede la mia scheda audio, e la configura. Ho settato tutti i volumi con alsamixer e con il front-end di gnome.
Tutti i livelli del volume sono al massimo, però l'audio non esce...
Dopo la configurazione ho riavviato il pc, non si sa mai...
Non so che fare. La scheda audio è riconosciuta, i volumi ci sono, ma niente volume (neanche da root...).

Che fare??

Sergej

chaosd
21-11-2004, 13:05
carica i moduli?
lancia lsmod e controlla se ci sono quelli per la tua scheda audio; a proposito che scheda è?

Sergej_D
21-11-2004, 13:11
La scheda è una C-Media Electronics Inc CM8738...
che modulo devo cercare??
CMQ: se non carico il modulo, non dovrebbe dirmi che nn trova la scheda??

Seergej

Sergio Pedone
21-11-2004, 13:15
Controlla che i cavi siano ben inseriti nelle varie prese e
che non sia applicato il mute in alsamixer.

ciao.

Sergej_D
21-11-2004, 13:19
I cavi sembrano inseriti bene... vado 1 minuto su windows e vede che succede.
CMQ, rifaccio la domanda: se alsa mi configura la scheda vuole dire che il modulo è caricato??

Sergej

chaosd
21-11-2004, 13:21
Originariamente inviato da Sergej_D
La scheda è una C-Media Electronics Inc CM8738...
che modulo devo cercare??
CMQ: se non carico il modulo, non dovrebbe dirmi che nn trova la scheda??

Seergej


non credo, alsaconf guarda se l'hardware è fisicamente connesso, non se attualmente attivo
cmq controlla nel kernel in Device drivers->Sound->alsa->pci devices :il modulo che ti serve deve ovviamente essere compilato come modulo ed è

C-Media 8738, 8338

poi esci, compila e butta il nuovo kernel
da runlevel 3 lancia alsaconf e buon divertimento!

Sergio Pedone
21-11-2004, 13:21
Si, sono d'accordo con te. Alsa configura la scheda solo quando
viene riconosciuta.

ciao.

Sergej_D
21-11-2004, 13:31
Quando lancio alsaconf trova la scheda e mi dice se voglio caricare il modulo snd_cmipci (che, evidentemente, riconosce come quello giusto).
MA poi, se non c'è scheda configurata, perchè alsamixer funziona? Perchè il gestore dei volumi di gnome funziona?
se non "sentisse" la scheda, beep-media-player non dovrebbe dirmi che non trova il dispositivo??

Anche kmix mi fa configurare la scheda e mi scrive il nome della scheda, giusto...

Sergej

Sergej_D
21-11-2004, 14:50
Ho risolto.
Ho visto che facendo partire una canzone con bmp non si sentiva niente, però se faccio cat /dev/dsp sento il suono, disturbato.
Con kmix hi visto che c'erano attivi una serie di dispositivi "strani".
Li ho tolti tutti e adesso sente bene :P

Sergej

Sergio Pedone
21-11-2004, 14:51
Bene. :)

Loading