PDA

Visualizza la versione completa : Installare connettore MSSQL con PHP


cecov74
22-11-2004, 14:54
Ho la necessitÓ di consultare php su MSSQL ho cercato in giro e sembra che la soluzione migliore sia http://www.freetds.org ho provato ad installarlo ma mi da errori


---------------------------------
/usr/local/include/sql.h:970: error: previous declaration of `SQLGetData'
odbc.c:4526: error: conflicting types for `SQLPutData'
/usr/local/include/sql.h:1067: error: previous declaration of `SQLPutData'
odbc.c:4630: error: conflicting types for `SQLSetConnectOption'
/usr/local/include/sql.h:1084: error: previous declaration of `SQLSetConnectOption'
odbc.c:4842: error: conflicting types for `SQLSetStmtOption'
/usr/local/include/sql.h:1130: error: previous declaration of `SQLSetStmtOption'
make[3]: *** [odbc.lo] Error 1
make[3]: Leaving directory `/home/stefan/archivio/freetds-0.62.4/src/odbc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/stefan/archivio/freetds-0.62.4/src/odbc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/stefan/archivio/freetds-0.62.4/src'
make: *** [all-recursive] Error 1

sembra che non trova gli altri connettori....
qualcuno sa come si fa? o altre soluzioni?

iamzamp
22-11-2004, 22:41
che distro usi?
hai fatto il compile dai sorgenti o da pacchetti?
se dai sorgenti, eri root?

hai seguito le istruzioni su http://www.freetds.org/userguide/php.htm

cecov74
24-11-2004, 11:42
Allora io seguo tutta la procedura e la cosa strana Ŕ che il ./configure non da errori mentre il make si.
Gli errori sono sempre gli stessi

odbc.c:606: error: conflicting types for `SQLParamOptions'
....

non potendolo installare non posso neanche testare php poi :'(

Loading