PDA

Visualizza la versione completa : Problemi con red hat 9


rossoweb
24-11-2004, 17:56
Salve, da pochi giorni ho installato la red hat 9 al posto di mandrake 10, solo che sto incontrando dei problemi... dalle distro capite subito che sono all'inizio :D ... ma bisogna pur iniziare :)

Allora, ecco i problemi:
1) ifconfig: command not found (su mandrake era ok)
2) visudo: command not found (su mandrake mai usato)
3) /etc/sudoers: anche modificandolo con vi, alla fine il file salva le modifiche ma il sistema non le reperisce. (su mandrake utilizzavo tranquillamente sudo)

Grazie a tutti per le eventuali delucidazioni :)

Ciauz :)

bakuryu
24-11-2004, 18:12
al posto di sudo, per le modifiche ai file prova a utilizzare i permessi, cio chmod.
esempio, se vuoi che un file diventi leggibile scrivibile e ed eseguibile da user prova:
# chmod 777 /home/file.sh
ma sconsigliabile dal punto di vista della sicurezza, quindi in genere prova:
# chmod 664 /home/file.sh

per la connessione ethernet dovrebbe avere dei programmi propri, anche grafici, ma redhat non la conosco :bh:

Sergio Pedone
24-11-2004, 18:28
Originariamente inviato da rossoweb
Salve, da pochi giorni ho installato la red hat 9 al posto di mandrake 10, solo che sto incontrando dei problemi... dalle distro capite subito che sono all'inizio :D ... ma bisogna pur iniziare :)

Allora, ecco i problemi:
1) ifconfig: command not found (su mandrake era ok)
2) visudo: command not found (su mandrake mai usato)
3) /etc/sudoers: anche modificandolo con vi, alla fine il file salva le modifiche ma il sistema non le reperisce. (su mandrake utilizzavo tranquillamente sudo)

Grazie a tutti per le eventuali delucidazioni :)

Ciauz :)
1) /sbin/ifconfig
2) /usr/sbin/visudo
3) dopo aver modificato il file /etc/sudoers, le modifiche sono attive dal login successivo

rossoweb
24-11-2004, 18:53
Grazie ragazi per le solerte risposte :)
Anche se ho capito qualche cosina, i problemi rimangono:

1) la scheda di rete l'ho configurata con il tool grafico, ma vorrei provare anche con ifconfig.
Nella cartella /sbin c' il file ifconfig, ma se provo a scriverlo mi da lo stesso errore, mentre se sscrivo #./ifconfig funziona :master:
2) trovato visudo nella cartella /usr/sbin e l'ho lanciato con #./visudo Problema risolto
3) modificando i permessi con chmod, modificato con visudo... problema identico.

In ogni caso grazie :fighet:

Ciuaz :)

untamed
24-11-2004, 19:32
Probabilmente, da utente, invece che dare il comando "su -", hai dato solo "su", per diventare root. In questo modo pero` non ha caricato il profilo. Usa "su -".

rossoweb
24-11-2004, 19:49
Niente da fare, per ho notato una cosa.
da utente se provo ad eliminare una cartella dove non ho i permessi, logisamente blocca l'operazione, invece se scrivo:


$sudo rm -r acrobat
elimino la cartella acrobat senza problemi, quindi sembra che sudo funzioni, mentre se provo:


$sudo mount -t smbfs..........
mi dice che mount: possibile solo per root

ma con mandrake lo facevo senza problemi :master: :dh: :dh:

Sergio Pedone
24-11-2004, 21:27
verifica nuovamente il file /etc/sudoers ed eventualmente postalo qui per i commenti del caso.

rossoweb
24-11-2004, 21:41
:yuppi: :yuppi: :yuppi: :yuppi: :yuppi: :yuppi:
Smanetta smanettando adesso sudo funziona :D

Sinceramente non ho capito il perch, avevo anche riavviato la macchina, ma niente, invece ora funziona, cmq sicuramente qualche errore mio c'era.

Grazie a tutti per la collaborazione, siete stati gentilissimi :)

Ciauz :ciauz:

Loading