PDA

Visualizza la versione completa : Non si avvia firefox 1.0


alex4988
27-11-2004, 15:19
Ecco qui l'errore che mi esce:


bash-2.05b$ firefox
No running windows found
LoadPlugin: failed to initialize shared library /opt/blackdown-jdk-1.4.1/jre/plugin/i386/mozilla/javaplugin_oji.so [/opt/blackdown-jdk-1.4.1/jre/plugin/i386/mozilla/javaplugin_oji.so: undefined symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsI ServiceManager]
bash-2.05b$

grazie mille

Guglie
27-11-2004, 15:26
dal messaggio sembra aver a che fare con la java wm, da quando è che non funziona firefox?
anche da root non parte?

alex4988
27-11-2004, 15:35
nn funziona da quando lo ho aggiornato alla 1.0 prima avevo la 1.0pre3 ora provo da root ma penso che l'errore sia lo stesso

alex4988
27-11-2004, 15:38
nemmeno da root parte

vortex87
27-11-2004, 15:39
Cancella il link al file che ti dice dalla directory plugins/ all'interno di quella dove hai installato Firefox :stordita:

E' un metodo brutale, ma anche a me Firefox da problemi con la jre (forse bisogna aggiornare, ma 80mb con un 56k :sonno: )

alex4988
27-11-2004, 15:50
Originariamente inviato da vortex87
Cancella il link al file che ti dice dalla directory plugins/ all'interno di quella dove hai installato Firefox :stordita:

E' un metodo brutale, ma anche a me Firefox da problemi con la jre (forse bisogna aggiornare, ma 80mb con un 56k :sonno: )
Nulla ora in bash nn mi dice più nulla in compenso mi esce un popup che dice
[CODE]
xml parsing error:undefined entity
Location:chrome://browser/content/browser.xul
line number 899 column 33
chromedir="&locale.dir;"

almafer
27-11-2004, 15:58
prova ad emergere di nuovo il blackdown-jdk

alex4988
27-11-2004, 16:01
emerso ma nulla


bash-2.05b# emerge -s blackdown-java3d-bin
Searching...
[ Results for search key : blackdown-java3d-bin ]
[ Applications found : 1 ]

* dev-java/blackdown-java3d-bin
Latest version available: 1.3.1
Latest version installed: 1.3.1
Size of downloaded files: 9,881 kB
Homepage: http://www.blackdown.org
Description: Java 3D Software Development Kit
License: sun-bcla-java-vm


bash-2.05b#




bash-2.05b# emerge -s firefox
Searching...
[ Results for search key : firefox ]
[ Applications found : 2 ]

* net-www/mozilla-firefox
Latest version available: 1.0
Latest version installed: 1.0
Size of downloaded files: 31,920 kB
Homepage: http://www.mozilla.org/projects/firefox/
Description: The Mozilla Firefox Web Browser
License: MPL-1.1 NPL-1.1

* net-www/mozilla-firefox-bin
Latest version available: 1.0
Latest version installed: 1.0
Size of downloaded files: 8,031 kB
Homepage: http://www.mozilla.org/projects/firefox
Description: The Mozilla Firefox Web Browser
License: MPL-1.1 NPL-1.1


bash-2.05b#

Sempre stesso errore pultroppo

vortex87
27-11-2004, 16:02
Prova a cancellare la directory .mozilla/firefox nella tua home :stordita:

Prima però copia i file bookmarks.html (segnalibri), signons.txt (password), cookies.txt (cookies) (nella cartella del tuo profilo) da qualche parte per poi ripristinarli ricopiandoli nella nuova cartella

alex4988
27-11-2004, 16:05
Originariamente inviato da vortex87
Prova a cancellare la directory .mozilla/firefox nella tua home :stordita:

Prima però copia i file bookmarks.html (segnalibri), signons.txt (password), cookies.txt (cookies) (nella cartella del tuo profilo) da qualche parte per poi ripristinarli ricopiandoli nella nuova cartella
mitico da root funge ora provo in utente

Loading