PDA

Visualizza la versione completa : driver 3d scheda video matrox g400


Ramk0
03-12-2004, 21:45
uso la debian sarge installata dalla rete, ho configurato i driver mga per l'uso standard, ma non ho messo i driver 3d, tralaltro non ho capito di preciso cosa devo installare non basta mettere i driver opengl? boh
io non sono molto esperto di queste cose... ho iniziato ad usare linux seriamente ora... infatti prima usavo la mandrake ora sono passato a debian... apparte questo piccolo problemino mi funziona tutto...

ho provato a far partire tuxracer ma va lentissimo e da un errore... cioè in breve dice che manca l'openGL... che devo fare? cercando con google ho trovato la libreria mesa che dovrebbe contenere anche l'opengl provo ad installare questo?

scusate se dico delle belinate ma in quanto driver per linux ci capisco ancora poco :D

Ramk0
04-12-2004, 03:09
se faccio glxinfo mi viene:
marco@marcolinux:~$ glxinfo
name of display: :0.0
libGL error: InitDriver failed
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 0 0 0 0 0 0 0 0 None
0x24 24 tc 1 24 0 r . . 8 8 8 0 0 0 0 0 0 0 0 0 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 0 0 24 8 0 0 0 0 0 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 0 0 24 8 0 0 0 0 0 0 None
0x27 24 tc 1 24 0 r y . 8 8 8 0 0 0 0 16 16 16 0 0 0 Slow
0x28 24 tc 1 24 0 r . . 8 8 8 0 0 0 0 16 16 16 0 0 0 Slow
0x29 24 tc 1 24 0 r y . 8 8 8 0 0 24 8 16 16 16 0 0 0 Slow
0x2a 24 tc 1 24 0 r . . 8 8 8 0 0 24 8 16 16 16 0 0 0 Slow
0x2b 24 dc 1 24 0 r y . 8 8 8 0 0 0 0 0 0 0 0 0 0 None
0x2c 24 dc 1 24 0 r . . 8 8 8 0 0 0 0 0 0 0 0 0 0 None
0x2d 24 dc 1 24 0 r y . 8 8 8 0 0 24 8 0 0 0 0 0 0 None
0x2e 24 dc 1 24 0 r . . 8 8 8 0 0 24 8 0 0 0 0 0 0 None
0x2f 24 dc 1 24 0 r y . 8 8 8 0 0 0 0 16 16 16 0 0 0 Slow
0x30 24 dc 1 24 0 r . . 8 8 8 0 0 0 0 16 16 16 0 0 0 Slow
0x31 24 dc 1 24 0 r y . 8 8 8 0 0 24 8 16 16 16 0 0 0 Slow
0x32 24 dc 1 24 0 r . . 8 8 8 0 0 24 8 16 16 16 0 0 0 Slow
marco@marcolinux:~$

e soprattutto quello che noto di più è "libGL error: InitDriver failed"...
non capisco che problema c'è... manca la libreria?
in sostanza se provo ad usare un qualunque programma che usa openGL
come tuxracer, mi da questo errore...

marco@marcolinux:~$ tuxracer
Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

libGL error: InitDriver failed
open /dev/sequencer: No such device

ah poi questo "open /dev/sequencer: No such device" ?

boh

andy caps
04-12-2004, 10:29
probabilmente dovresti installare un po di file di glu e glut e magari mgapdesk gmgaclock

prova

apt-get install libglui2c102 libglut3 libglut3-dev mgapdesk gmgaclock

o comunque dai un apt-cache search glu e vedi di installare qualcosa
non seguo molto gli sviluppi di glut
poi prova a lanciare mgapdesk

Ramk0
04-12-2004, 14:27
ok intanto provo a fare queste cose... poi se ci sono problemi torno qui :D

Loading