PDA

Visualizza la versione completa : DEBIAN ma dov'è php.ini


winforum
04-12-2004, 23:58
scusate ho appena installatp php5 su debian

sembra sia andato tutto bene (ho compilato)

ma non riesco a trovare php.ini

quancuno sa dirmi dove dovrebbe essere e perchè non lo trovo?

grazie

wittgen105
05-12-2004, 00:35
Normalmente si trova in /usr/local/lib/php.ini

:)

innovatel
05-12-2004, 02:45
$ su
password:
# updatedb
# locate php.ini


:D

winforum
05-12-2004, 15:00
Ho provato ma non lo trova,

non riesco a capire, ho provato ad installare anche php4 ma stessa cosa non trova php.ini

Ho porvato anche ad installarlo come modulo di apache2 ma quando provo a configure apache
./configure --activate-module=.....libphp4.a


mi dice che non trova il comando è sbagliato, ho provato anche a cercare libphp4.a ma non trovo nemmeno quello, è come se quando installo php sono installasse tutto

qualcuno sa darmi qualche delucidazione?

innovatel
05-12-2004, 18:15
dato che usi debian, guarda qua (http://www.innoland.it/modules/news/article.php?storyid=146) e addio le compilazioni :D

wittgen105
06-12-2004, 00:00
Prova a trovarlo così:

$ find / -name php.ini -print

:ciauz:

winforum
06-12-2004, 14:37
Grazie ho provato tutto bene, all'inizio non mi interpretava php ma tentava di scaricare le pagine, ma poi guardando un po il file di configurazione di apache ho notato che la parte sull'importazione del modulo di php era commentato dunque dopo averlo decommentato è andato tutto.

Devo ancora provare a collegarmi a mysql ma spero non insorgano problemi.

Grazie ancora...


Ma se per caso volessi installare apache2 sempre su debian si può fare con apt?
Ho provato con apt-get install apache2 ma nulla...

wittgen105
06-12-2004, 14:43
Dipende dalle versione che hai. Se devi usare apt-get assicurati che nella tua distro sia presenta il pacchetto che cerci di installare.

Per esempio nella mia woody apache2 non è presente perciò se lo volgio installare devo scaricare i sorgenti. Se invece hai una versione più recente, per esempio la testing, sicuramente è presente già apache2 e quindi puoi tranquillamente dare:
apt-get install apache2



:ciauz:

winforum
06-12-2004, 15:20
Ok grazie, un po come immaginavo,

tutti i miei problemi erano iniziati volendo compilare apache2 cosa che in effetti aveva funzionato, è php5 che non andava, dalla compilazione sembrava tutto ok invece non esistevano librerie e il famoso php.ini.

Ora ho installato con apt apache 1.3... e php4 e tutto va perfettamente.

tra un po proverò a ricompilare apache2 e usarlo con php4 invece del 5 e vedere cosa succede.

Grazie a tutti.

innovatel
06-12-2004, 16:43
per il due mi sembra ci sia ... però parlo per la sid

prova a fare apt-get per la ricerca con la chiave apache oppure usa synaptic che è molto più semplice.

(se non hai synaptic installalo con apt-get e vai tranquillo)

Loading