PDA

Visualizza la versione completa : se si blocca apt-get dist-upgrade


sopadj1
06-12-2004, 11:49
salve gente!
come da titolo, e si si blocca il dist-upgrade mentre sta spaccettando/installando/configurando i pacchetti installati



Spacchetto il rimpiazzo di libsnmp-base ...
Sono occorsi degli errori processando:
/var/cache/apt/archives/freenx_0.2.7-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
# _


cosa bisogna fare?

io ho dato un

apt-get install -f

sufficiente?

francofait
06-12-2004, 11:58
Originariamente inviato da sopadj1
salve gente!
come da titolo, e si si blocca il dist-upgrade mentre sta spaccettando/installando/configurando i pacchetti installati



Spacchetto il rimpiazzo di libsnmp-base ...
Sono occorsi degli errori processando:
/var/cache/apt/archives/freenx_0.2.7-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
# _


cosa bisogna fare?

io ho dato un

apt-get install -f

sufficiente?

dpkg --configure -a per completare , se apt-get -f install riuscito a risolvere le dipendenze completando il pacchetto , poi dpkg ti completa l'installazione e te lo configura.

sopadj1
06-12-2004, 12:04
grazie

sopadj1
06-12-2004, 12:08
Originariamente inviato da francofait
dpkg --configure -a per completare , se apt-get -f install riuscito a risolvere le dipendenze completando il pacchetto , poi dpkg ti completa l'installazione e te lo configura.

dpkg-reconfigure -a

:oVVoVe: :oVVoVe:

devo per forza diconfigurare tutti i pacchetti.... :(

andy caps
06-12-2004, 14:59
dpkg --configure -a :D il comando

dpkg-reconfigure -a ti fa rifare tutti i settaggi dell'installazione

Loading