PDA

Visualizza la versione completa : aggiornare samba


MatildaB
09-12-2004, 11:38
premetto che uso fedora core 2...
mi vedo costretto ad aggiornare samba perche' da quello che ho capito e' l'unico sistema per far funzionare macchine con xp pro sp2 nel mio dominio, infatti con una non aggiornata non ho problemi, mentre con le altre non riesco ad autenticarmi e ho un sacco di problemi....
la domanda e' questa...
come posso fare ad aggiornare samba?
ho scaricato il file rpm dal sito di fedora, ma se faccio l'installazione rpm -Uvh samba-3.0.9-1.fc2.src.rpm pur sembrando terminata con successo mi ritrovo sempre la stessa versione di samba....
se invece prendo l'aggiornamento rpm -Uvh samba-3.0.9-2.i386.rpm mi ritrovo con dei problemi di dipendenze :
error: Failed dependencies:
liblber-2.2.so.7 is needed by samba-3.0.9-2
libldap-2.2.so.7 is needed by samba-3.0.9-2
samba-common = 0:3.0.9 is needed by samba-3.0.9-2
samba = 0:3.0.3 is needed by (installed) samba-swat-3.0.3-5
cosa devo fare?

Kandalf
09-12-2004, 13:42
metti una distro col gestore di pacchetti

oppure vai su rpmfind.net e cercati tutte le dipendenze e installae nelle versione giuste

wittgen105
09-12-2004, 14:25
Perchè non scarichi i sorgenti sa www.samba.org ??? Poi compilali, se ti da qualche problema installa le librerie che mancano dal gestore dei pacchetti che hai installato di serie sulla tua distro!

:ciauz:

MatildaB
10-12-2004, 01:16
nel frattempo che aspettavo risposte ho fatto un tentativo... consideratelo strano o sciocco...o forse o fatto la strada più lunga, comunque mi sono installato apt-get e ho fatto un aggiornamento complessivo del sistema... dopo circa 2 ore e oltre 600M di aggiornamenti il sistema si e' aggiornato con nuovo kernal e tutto il resto , ivi compreso samba alla 3.0.9... domani finisco il tutto e provo... vi terrò aggirnati.

Loading