PDA

Visualizza la versione completa : Kernel 2.6 e kernel panic non atteso


Leonardo Arte
17-12-2004, 20:00
Ciao,

ho installato la slackware 10 su un PC nuovo nuovo dell'ultimissima generazione. Non ci sono problemi con il kernel installato di default 2.4.26, mentre, nel momento che vado a compilare il 2.6.9 ho al momento di reboot un bel kernel panic che indicato in queste righe:
-----
VFS: cannot open root device "302" or unknown-block(3,2)
Please append a correct "root=" boot option
Kernel panic: not syncing: VFS: Unable to mount root fs on
unknown-block(3,2)
-----

Per ricompilare il kernel ho utilizzato il .config che ho trovato negli extra (kernel serie 2.6) della slackware 10 e perci teoricamente quel kernel dovrebbe funzionare sulla maggior parte degli hardware.

Fatto st che non funziona e mi da sempre il Kernel panic. Avete a portata di mano qualche informazione a riguardo?

PS: un bel po' che smanetto con kernel e slackware (4-5 anni) e non avevo mai avuto questo tipo di problemi.

Qualche idea? Ahh dimenticavo il file sistem ext3 ed ho abilitato in maniera statica il suo supporto nel kernel.

Fate mi sapere

almafer
17-12-2004, 20:05
ma il lilo.conf (o grub) lo hai sistemato?

andy caps
17-12-2004, 21:15
guarda la guida di pierluigi tra le risorse del forum

se hai fatto qualche errore di procedura con quello risolvi
altrimenti devi ricontrollare il kernel
la conf della slack dovrebbe mettere un kernel quasi tutto modulare e puo sucedere che non riesca a caricare qualcosa

Leonardo Arte
18-12-2004, 09:31
Originariamente inviato da almafer
ma il lilo.conf (o grub) lo hai sistemato?

B stata la prima cosa che ho ricontrollato :dh:

Leonardo Arte
18-12-2004, 09:31
Originariamente inviato da andy caps
guarda la guida di pierluigi tra le risorse del forum

se hai fatto qualche errore di procedura con quello risolvi
altrimenti devi ricontrollare il kernel
la conf della slack dovrebbe mettere un kernel quasi tutto modulare e puo sucedere che non riesca a caricare qualcosa

Ora gli riprovo a dare una occhiata :messner:

marasma1
20-03-2005, 10:21
Ciao anche io ho riscontrato lo stesso problema....
Lo hai risolto?

Leonardo Arte
20-03-2005, 13:32
Si ;)

cambiare nel lilo i vari sda1 sdb1 etc etc in "sga1" ed "sgb1" etc etc ;)

Occhio che un cambiamento radicale ;)

marasma1
20-03-2005, 18:22
ma io ho solo hda1, hda2,ecc... :nonono:

kyraz
21-03-2005, 20:06
di solito quando succede questo ci siamo dimenticati di compilare nel kernel (non come modulo) il supporto per il controller ide del nostro pc.

Loading