PDA

Visualizza la versione completa : [Mandrake 10.1] Kernel panic


asiul
18-12-2004, 17:36
Rieccomi a chiedere aiuto! :cry:
Ho installato per la prima volta, 2 giorni, fa Mandrake 10.1.
Ero felicissima perché è stato facile ma oggi l'ho spento, sono uscita (regali di Natale :incupito: ), sono tornata e non si avvia!
Mi da un errore:

Kernel panic: Fatal exception interrupt
Interrupt handler - not syncing

L'ho installato su una partizione dell' hd, mentre su un'altra partizione continua ad esistere win xp, da cui adesso sto scrivendo! :cry:
Ovviamente mentre ero fuori l'ha usato mio padre, accuratamente istruito sull'accendere il pc e far partire win da solo, perché dopo 10 sec parte win. Lui sostiene di non aver fatto niente e non posso smentirlo perché non ci capiso proprio niente!

Non sarebbe un dramma doverlo installare di nuovo, tanto in 2 giorni non ci ho messo niente di importante.
Ma non c'è modo risolvere?
E soprattutto sapete perché mi da quell'errore?
E' molto grave?
A leggerlo sembra un messaggio di coma irreversibile! :cry:
Nel caso dovessi reinstallarlo devo prima formattare? Da dove? Da win non vedo la partizione di linux però ho Partition Magic e da lì la vedo..potrebbe servire a qualcosa? :bhò:
Io non faccio niente, non vorrei fare danni peggiori, quindi aspetto una risposta!
:ciauz:

Gionnico
18-12-2004, 18:43
Non ho idea dell'errore, ma posso dirti che partition magic va bene: cancelli sia la swap, che la partizione principale. Altrimenti ti basta reinsesrire i dischi di installazione, ed arrivati al momento della "partzionatura" gli dici di cancellare le due (o più) partizioni di liux, è lo stesso.

francofait
18-12-2004, 18:57
Non c'è alcun bisogno di riformattare , ripeti semplicemrnte l'installazione usando le partizioni linux esistenti , a riformattarle prima di proseguire con l' installazione ci pensa da se. Imposta invece reiserfs cme fs .
:ciauz: :ciauz: :ciauz:

asiul
18-12-2004, 19:27
Grazie!
Ma secondo voi se rienstallo tutto risolvo?
Io non mi sono resa conto di aver cambiato qualche impostazione e quindi non vorrei che fosse un problema più grave!
Ho cercato nel web qualcosa in proposito.
Vengono fuori solo pagine in inglese...il problema non è capire l'inglese, il problema è capire esattamente cosa quei tipi consigliano di fare! Sono decisamente alle prime armi!
Posso postare l'indirizzo di quel forum dove ho trovato qualche notizia?
:ciauz:

francofait
18-12-2004, 19:33
Se hai a disposizione una distribuzione livecdrom molto probabilmente potresti ripristinare senza reinstallare , editando
il file /etc/lilo.conf e modificando le opzioni in append cosi:
append = " apm=off acpi=on acpi=force noapic nolapic "
Poi entrare con chroot /hdxx (xxla tua partiz / di Mdrake) e da console inpartire - lilo -v x aggiornare il bootloader
:ciauz: :ciauz:

francofait
18-12-2004, 19:40
Originariamente inviato da francofait
Se hai a disposizione una distribuzione livecdrom molto probabilmente potresti ripristinare senza reinstallare , editando
il file /etc/lilo.conf e modificando le opzioni in append cosi:
append = " apm=off acpi=on acpi=force noapic nolapic "
Poi entrare con chroot /hdxx (xxla tua partiz / di Mdrake) e da console inpartire - lilo -v x aggiornare il bootloader
:ciauz: :ciauz:

Se decidi di reinstallare . fai attenzione in fase finale accedi alle funzioni di modifica delle opzioni di boot ed inserisci le opzioni x acpi e apic come sopra.


:ciauz: :ciauz:

asiul
18-12-2004, 19:47
Originariamente inviato da francofait
Se hai a disposizione una distribuzione livecdrom molto probabilmente potresti ripristinare senza reinstallare , editando
il file /etc/lilo.conf e modificando le opzioni in append cosi:
append = " apm=off acpi=on acpi=force noapic nolapic "
Poi entrare con chroot /hdxx (xxla tua partiz / di Mdrake) e da console inpartire - lilo -v x aggiornare il bootloader
:ciauz: :ciauz:

Ho Knoppix livecd.
Ora non ho tempo per cercare di capire cosa mi stai dicendo di fare! :cry:
Però nella mia ricerca avevo trovato qualcosa di simile:
****************************************
Reboot and as soon as you see the lilo screen hit the Esc key which will take you to a boot prompt. At the prompt type in the following:

linux noapic nolapic acpi=off

and hit the Enter key.

****************************************
Unfortunately there is a serious conflict or kernel bug.

ACPI is used to manage Interrupt routing but by including the acpi=off you've disabled it.

This causes the kernel to use the bios defaults which are not always correct or applicable, nor are all IRQ's and IRQ sharing correctly reported.

This kills the IRQ handling process in the kernel causing the error you see.

First see if you can enable ACPI.

Then in the BIOS set the PNP OS entry to read NO save and exit.

At worst, open the machine and try to move some of the cards around.

Usually when the above happens (at boot) it is because the IRQ allocated to the IDE or drive controller, is being shared with another device, but the kernel does not know about the other device due to the lack of ACPI support on an ACPI system...

Also note that a later kernel will often address these issues a bit better. I've seen cases where-in the same message is printed AFTER startup or shutdown by an AGP driver, etc. and a kernel upgrade was better able to deal with the IRQ event handler.
****************************************
Ma non ho idea di come fare!
Quando lo leggevo credevo che fosse arabo o greco!

In più mi piacerebbe capire se questo è un problema che posso risolvere reinstallando tutto oppure se mi si ripresenterà! :master:
Mi sembra che la sfiga mi perseguiti!
Prima con il modem e ora con questo kernel panic! :cry:
:ciauz:

francofait
18-12-2004, 20:29
Originariamente inviato da asiul
Ho Knoppix livecd.
Ora non ho tempo per cercare di capire cosa mi stai dicendo di fare! :cry:
Però nella mia ricerca avevo trovato qualcosa di simile:
****************************************
Reboot and as soon as you see the lilo screen hit the Esc key which will take you to a boot prompt. At the prompt type in the following:

linux noapic nolapic acpi=off

and hit the Enter key.

****************************************
Unfortunately there is a serious conflict or kernel bug.

ACPI is used to manage Interrupt routing but by including the acpi=off you've disabled it.

This causes the kernel to use the bios defaults which are not always correct or applicable, nor are all IRQ's and IRQ sharing correctly reported.

This kills the IRQ handling process in the kernel causing the error you see.

First see if you can enable ACPI.

Then in the BIOS set the PNP OS entry to read NO save and exit.

At worst, open the machine and try to move some of the cards around.

Usually when the above happens (at boot) it is because the IRQ allocated to the IDE or drive controller, is being shared with another device, but the kernel does not know about the other device due to the lack of ACPI support on an ACPI system...

Also note that a later kernel will often address these issues a bit better. I've seen cases where-in the same message is printed AFTER startup or shutdown by an AGP driver, etc. and a kernel upgrade was better able to deal with the IRQ event handler.
****************************************
Ma non ho idea di come fare!
Quando lo leggevo credevo che fosse arabo o greco!

In più mi piacerebbe capire se questo è un problema che posso risolvere reinstallando tutto oppure se mi si ripresenterà! :master:
Mi sembra che la sfiga mi perseguiti!
Prima con il modem e ora con questo kernel panic! :cry:
:ciauz:




Be' reinstallando il problema lo risolvi alla fonte come ti ho spigato prima.
Quando arrivi alla pagina riassuntiva finale , prima di chiudere l'installazione accedi alle funzioni di boot ed aggiorni subito le funzioni di append x il bootloader come ti ho indicato in precedenza.

asiul
19-12-2004, 09:46
Originariamente inviato da francofait
Be' reinstallando il problema lo risolvi alla fonte come ti ho spigato prima.
Quando arrivi alla pagina riassuntiva finale , prima di chiudere l'installazione accedi alle funzioni di boot ed aggiorni subito le funzioni di append x il bootloader come ti ho indicato in precedenza.

Non avevo visto il messaggio sopra perché quando l'hai scritto stavo scrivendo anche io! :)
Spero di trovare, durante l'installazione, quelle opzioni perché non ricordo di averle viste la prima volta, però non sapevo nemmeno che esistessero, quindi..... :stordita:
Se non ho capito male nella pagina finale dove c'è tutto (periferiche ecc) in fondo c'è anche qualcosa per il boot, giusto?
Da lì dovrei trovare delle opzioni da modificare nel modo che mi hai detto, giusto? Mi devo aspettare un quadratino da spuntare o cosa?
Mi sento un po' stupida, ma sono davvero alle prime armi; la procedura di installazione l'ho fatta una sola volta, quindi non l'ho memorizzata molto bene e poi non vorrei trovarmi davanti qualcosa che non mi aspetto, perché a quel punto non potrei usare il pc per venire qui a chiedere aiuto! :cry:

Ma mi sai spiegare anche il perché di quel problema?
Perché il kernel se l'è presa proprio con me?? :dhò:
Grazie!
:ciauz:

andy caps
19-12-2004, 10:29
a meno che qualcuno non tocchi la configurazione d lilo nel centro di controllo di mandrake > boot questo problema non sussiste

puo darsi che avviando mcc ( la sezione boot è la prima che mostra ) tuo papa sia entrato per sbaglio nella configurazione di lilo ed abbia cambiato qualche parametro

:bhò: altre spiegazioni non ne saprei trovare

reinstalla tranquillamente non ho mai visto un kernel panic con l'installazione di mandrake

Loading