PDA

Visualizza la versione completa : strano problema al mouse [mdk10.1Official]


IroN@xiD
20-12-2004, 22:00
Ciao a tutti!!! :)

Ho un problema con la nuova release di mandrake, non mi funziona il mouse. O meglio, funziona benissimo ma soltanto dopo aver selezionato un altro tipo di mouse.

Quando avvio il pc e kde mi trovo il mouse piantanto, come non esistesse. Entro nel centro di controllo, cambio il mouse (è selezionato "universale->qualsiasi mouse PS/2 USB") in PS/2->mouse generico con rotellina, confermo, vado in un terminale a caso poi rientro in X e il mouse funziona alla meraviglia.

A questo punto mi sono chiesto una cosa, ma perchè non conserva il mouse che imposto?!? Per caso qualche parte dei sorgenti che hanno sottratto a microsoft è finito in mezzo al codice di linux??? :oVVoVe:

Qualcuno mi può aiutare? :(

Grazie mille!!! :)

Ciao a tutti!!

eddis
20-12-2004, 22:10
Modifica direttamente il file /etc/X11/xorg.conf

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Questo su Mdk 10.1 funziona.

IroN@xiD
20-12-2004, 22:46
ho provato ma non risolve. Il mouse rimane sempre bloccato finchè non avvio mousedrake e reimposto su PS/2 generico con rotellina :cry:

perchè!?!? :dhò:
perchè!?!?!?!?!?!? :nonlodire

Eppure è natale!!! Dovrebbero essere tutti più buoni... :incupito:

alex86
20-12-2004, 23:18
allora..
porva a lanciare xorgconfig senza entrare in X
(puoi anke far partire x e poi nella shell scrivi init 3 come root) quindi..lanci il programma e configuri tutto

scegli il mouse ps2 e dici so all'attivazione di "emulate 3button"

una volta fatta tutta la configurazione, apri il file xorg.conf (ad esempio pico /etc/X11/xorg.conf) e nella sezione mouse aggiungi:

Option "ZAxisMapping" "4 5"
Option "Emulate 3Button" "no"

kiudi (se lo fai con pico ctrl+x e y per salvare) e avvii x con start X


p.s. un consiglio!controlla prima la frequenza orizz e verticale del tuo monitor così come è ora..lo puoi vedere dal file xorg.conf ke hai ora nella sezione monitor! (ad esempio io ho 30-70 come verticale e 60-85 come orizzontale)

Ilmalcom
20-12-2004, 23:32
Originariamente inviato da IroN@xiD
Ciao a tutti!!! :)

Ho un problema con la nuova release di mandrake, non mi funziona il mouse. O meglio, funziona benissimo ma soltanto dopo aver selezionato un altro tipo di mouse.

Quando avvio il pc e kde mi trovo il mouse piantanto, come non esistesse. Entro nel centro di controllo, cambio il mouse (è selezionato "universale->qualsiasi mouse PS/2 USB") in PS/2->mouse generico con rotellina, confermo, vado in un terminale a caso poi rientro in X e il mouse funziona alla meraviglia.
Quasi sicuramente è colpa di udev che pasticcia, sistema in maniera adeguata le rules per il mouse in /etc/udev/rules.d

andy caps
20-12-2004, 23:48
prova anche a scrivere

psmouse

in /etc/modprobe.preload
magari caricandolo all'avvio poi lo trova

IroN@xiD
21-12-2004, 00:08
con il file xorg.conf creato attraverso xorgconfig non mi parte più nemmeno x anche se apparentemente faccio tutto come si deve... :(

Ho rimesso il file di conf originale e X non mi riparte più nemmeno con quello.. Evviva!! :D

Penso che proverò a reinstallare...

alex86
21-12-2004, 00:16
ma noooooo ke reinstallare :) maledetto windows..

dicci l'errore :)

IroN@xiD
21-12-2004, 00:26
eheh, ti giuro che prima di fare refresh della pagina ho pensato la stessa cosa... :cry:

Perdono!! Mi rifarò! :)

Dice che la modalità impostata (depth) a 16 non è supportata dal driver. Trova lo schermo ma non c'è una configurazione utilizzabile :stordita:

Domandina ( :yuppi: ) : Ma xorgconfig non dovrebbe modificare solamente il file xorg.conf?
Io avevo fatto un backup prima di usare xorgconfig, come mai adesso anche se ripristino il backup non mi funziona più?

alex86
21-12-2004, 00:37
allora..

è un problema di bit..
fai così da root
cp /etc/X11/xorg.conf.back /etc/X11/xorg.backup

apri con pico /etc/X11/xorg.conf
nella sezione "screen" c'è una variabile
DefaultDepth 16

te impostala a
DefaultDepth 24


ti posto tutta la mia sezione screen


Section "Screen"
Identifier "Screen 1"
Device "107e"
Monitor "107e"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection


magari se hai un monitor 17 pollici settala uguale..

se non va dai questi comandi da root

rm /etc/X11/xorg.conf
cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

Loading