PDA

Visualizza la versione completa : Lilo : windows non parte!


andrea_NET-_DSL
24-12-2004, 10:54
Ho la seguente configurazione di lilo (tratta da /etc/lilo.conf)

boot="/dev/hda"
lba32
prompt
timeout="100"
root=/dev/hda5
vga="791"

image="/boot/vmlinuz"
label="Linux"
root="/dev/hda5"
read-only
optional

other=/dev/hdb1
label="NT"

image="/dev/hdb1"
root="/dev/hda5"
ma quando all'avvio seleziono NT e do invio rimane li senza avviare nulla...mentre linux(slackware 10) parte senza problemi!

help! :stordita: :dhò:

Buon Natale :D

:)

francofait
24-12-2004, 10:59
other=/dev/hdb1
label="NT"

image="/dev/hdb1"
root="/dev/hda5"

che è sto casino qui
cancella immediatamente

quella patacca finale
errore gravissimo
image="/dev/hdb1"
roor="/dev/hda5"

e rilancia lilo -v

andrea_NET-_DSL
24-12-2004, 11:04
Quindi cosa devo cancellare e/o modifcare per far si che mi parta windows xp?
thz :zizi:

andrea_NET-_DSL
24-12-2004, 12:49
Essendo Windows Xp nell'hd sul primary slave mentre linux sul primary master ho dovuto editare cosi' /etc/lilo.conf



boot="/dev/hda"
lba32
prompt
timeout="100"
root=/dev/hda5
vga="791"
default=Linux


#Avvio Linux Slackware
image="/boot/vmlinuz"
label="Linux"
root="/dev/hda5"
read-only


#Avvio Windows Xp
other=/dev/hdb1
label="Windows"
table=/dev/hdb

#le seguenti 4 righe dicono
#a LILO di far credere che
#i dischi rigidi siano scambiati, cioè
#che lo slave primario sia sul
#master primario e viceversa

map-drive=0x80
to = 0x81
map-drive=0x81
to = 0x80



ciauz! :)

francofait
24-12-2004, 13:15
OK e Buon Natale

:ciauz: :ciauz: :ciauz: :ciauz:

andrea_NET-_DSL
24-12-2004, 14:21
Originariamente inviato da francofait
OK e Buon Natale

:ciauz: :ciauz: :ciauz: :ciauz:
Buon Natale a te :ciauz:

Ecco una versione di lilo.conf ben commentata a chi ,in futuro,ne avrà bisogno :D

#/etc/lilo.conf
#Configurazione di lilo nel caso che linux si trovi sul disco in Primary Master
#mentre windows su quello in Secondary Master

boot="/dev/hda" #lilo verrà installato qua
lba32 #prende i parametri dell'hd dal bios
prompt #fà visualizzare la schermata di lilo
timeout="100" #Tempo di attesa prima di eseguire la scelta di default,espresso in ms
root=/dev/hda5
vga="791" #Risoluzione video
default=Linux #S.O. avviato di default


#Avvio Linux (Slackware 10 in questo caso)
image="/boot/vmlinuz" #immagine del kernel
label="Linux"
root="/dev/hda5" #partizione dove si trova linux
read-only #le partizioni linux devono sempre essere avviate in SOLA scrittuta



#Avvio Windows Xp
other=/dev/hdb1 #partizione dove si trova windows
label="Windows"
table=/dev/hdb #carico la tabella delle partizioni del disco in questione

#le seguenti 4 righe dicono
#a LILO di far credere che
#i dischi rigidi siano scambiati, cioè
#che lo slave primario sia sul
#master primario e viceversa

map-drive=0x80
to = 0x81
map-drive=0x81
to = 0x80




:)

Loading