PDA

Visualizza la versione completa : Drivers nVidia


/dev/null
29-12-2004, 04:10
Devo mettere i drivers invidia sulla Debian (Knoppix per l'esattezza) d'un mio amico...
Ho scaricato NVIDIA-Linux-x86-1.0-6629-pkg1.run, ma se provo ad eseguirlo mi dice che mi mancano i sorgenti del kernel...
Ho apt-get installato i sorci del kernel, gli headers, i sorci dell'nvidia-kernel e tanta altra roba, ma ottengo sempre lo stesso deludente risultato...
Posto il log: /var/log/nvidia-installer.log, scusate se e' un po' lunghetto :zizi:

Troppo lungo :rollo: lo trovate qui': http://edt.altervista.org/nvidia-installer.log


L'unica altra volta che ho installato i drivers per un'nvidia non ho dovuto fare praticamente nulla :bh:


:ciauz:

robyro
29-12-2004, 10:17
io sulla sid ho dato: "apt-get install nvidia-kernel-source"
in /usr/src mi ha installato "nvidia-kernel-source.tar.gz" solito tar xzvf e dpkg-reconfigure xserver-xfree86 e funge

/dev/null
29-12-2004, 17:53
Originariamente inviato da robyro
io sulla sid ho dato: "apt-get install nvidia-kernel-source"
in /usr/src mi ha installato "nvidia-kernel-source.tar.gz" solito tar xzvf e dpkg-reconfigure xserver-xfree86 e funge OK :) Appena torna proviamo a farlo...
Per ora ho risolto, ma solo col 2.4 e preferivo fargli avere un 2.6...
Mi e' bastato reboottare col kernel 2.4 anziche' il 2.6 e lo script dell'nvidia ha fatto tutto da solo in un istante come aveva fatto su quella vecchia suse :D

discepolo
29-12-2004, 18:12
Originariamente inviato da robyro
io sulla sid ho dato: "apt-get install nvidia-kernel-source"
in /usr/src mi ha installato "nvidia-kernel-source.tar.gz" solito tar xzvf e dpkg-reconfigure xserver-xfree86 e funge

e cosi hai installato il modulo di nvidia

:stordita:

[\_/|\_/]
12-02-2005, 21:20
anch'io ho lo stesso problema...
Ho provato a fare come dice robyro ma nn funge ugualmente.

Altre idee?

Approposito sapete anche dirmi dove si trovano adsl-* per debian?
Sapevo che questi programmi stavano dentro il pacchetto rp-pppoe ma ho visto che nn c' sul mio apt.

Ciao

andy caps
12-02-2005, 21:35
a molti basta installare i kernel-headers esatti del proprio kernel (uname -r) li installa anche l'installer della nvidia


debian non ha rp-pppoe

usa pppoeconf e per connettersi usa pon

[\_/|\_/]
12-02-2005, 21:41
Originariamente inviato da andy caps
a molti basta installare i kernel-headers esatti del proprio kernel (uname -r) li installa anche l'installer della nvidia


debian non ha rp-pppoe

usa pppoeconf e per connettersi usa pon Ok, ora provo a configurare il modem...
Riguardo all'nVidia... Con synaptic ho cercato tutti i pacchetti contenenti nvidia e li ho installati tutti, ed ho scaricato il sorgente del kernel mio kernel (2.4.27) ho visto che ha messo in /usr/src il pacchetto senza estrarlo e quindi l'ho fattio io a mano ed aggiornato il symlink linux... Ma non cambia nulla...
Se gli dico di scaricarmi i sorgenti dal sito dell'nVidia mi fallisce miseramente... :fagiano:

andy caps
12-02-2005, 21:47
che modem ?

pppoeconf serve per i modem ethernet con protocollo pppoe

[\_/|\_/]
12-02-2005, 21:57
Originariamente inviato da andy caps
che modem ?

pppoeconf serve per i modem ethernet con protocollo pppoe Si' :) e' proprio un modem ethernet.
L'ho sempre configurato su ogni distribuzione usando rp-pppoe, ma ho visto che su questa debia non e' presente tale pacchetto ne' i programmi che contiene.

Il problema maggiore e' la scheda video :incupito: non posso vivere senza QuakeIIIArena :stordita:

andy caps
12-02-2005, 22:13
non so che debian hai installato su una sarge giorni fa ho visto che bastato scaricare il kernel-headers
dai un uname -r e poi cerca con apt-cache search kernel-headers i sui ed installi

devi dare semmai prima di installarli un

modprobe -r rivafb
poi dopo averli installati senza fargli cercare su internet basta un modprobe nvidia e correggere

/etc/X11/XF86Config-4 cosi in queste due sezioni

Section "Module"
#Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
EndSection

Loading