PDA

Visualizza la versione completa : Trasformare ubuntu in una distro normale


Kamui
29-12-2004, 17:42
:D

Ultimamente ce la stanno mettendo tutta per trasformare linux in qualcosa di criptico :dottò:

Sorvolando sulla scelta di disabilitare root di default :oVVoVe: sto cercando di far avere a ubuntu un'impostazione standard.
Con sudo -s (+ mia_password) sono diventato root, da qui ho definito la password di root con il comando passwd, dopodichè ho aggiunto root tra gli utenti loggabili in gdm.

Mi sloggo, con root posso entrare e come utente no. Entro da root, creo la directory /home/utente e la chowno all'utente, mi sloggo e riprovo. Nulla, altro errore, ho dovuto riavviare la macchina per rendere effettive le modifiche (evvai :zizi: )

Una volta riavviato, mi loggo tranquillamente, ma con sudo -s + passwd_utente ancora posso diventare root. Quando vado nei menu di amministrazione e mi richiede la password, devo inserire quella utente e non quella di root. Quindi uso visudo per editare il file sudoers e impedire che il mio utente normale sia Dio in terra. Dico ora anzichè la pwd utente mi ci vorrà quella di root... macchè, con quella utente non posso entrare, ma nemmeno con quella di root.

Tra l'altro sono dovuto andare nelle impostazioni utenti e aggiungere root a tutti i gruppi perchè non aveva permessi :oVVoVe: questo è quantomeno blasfemo :D

Cmq... suppongo che per trasformare ubuntu in una distro standard mi manchi solo da modificare qualche opzione in gnome, in modo che se cerco di avviare strumenti di sistema mi chieda la pwd di root e non quella di utente. Come fo?

andy caps
29-12-2004, 19:20
per abilitare l'utente root comunque basta editare il file /etc/kde3/kdm/kdmrc e mi sembra alla riga 233 donìve è scritto
allowRootlogin=false mettere allowRootlogin=true

se usi gnome devi editare gdm.conf in etc/gmome/gdm probabilmente e fare la stessa operazione

anche a me comunque non è piaciuta molto quella scelta :rollo:

Kamui
29-12-2004, 19:36
Sì ma il login a gdm lo posso fare (bastava editare le opzioni anche in modalità grafica), è quando sono utente in gnome che mi chiede una password che non è quella di root per fare cose da root (e.g. Computer -> System configuration -> Utenti e gruppi).

E' normale inoltre che anche dopo aver decommentato i repository e fatto apt-get update, non ci sia firefox 1.0? nè le sdl 1.2.8 :dottò: Perchè totem non mi apre alcun filmato? :fagiano:

Non voglio mettere le rep di sid, preferisco tenere quelle di ubuntu.

andy caps
29-12-2004, 19:44
non so che repository hai

io adesso ho messo quelle della hoary e dopo avere tirato giu quasi tutto della warty ho messo xorg e mi sembra che trovi tutto compreso firefox 1

root@andy:/ # dpkg -p mozilla-firefox
Package: mozilla-firefox
Priority: optional
Section: web
Installed-Size: 26260
Maintainer: Eric Dorland <eric@debian.org>
Architecture: i386
Version: 1.0-2ubuntu3
Provides: www-browser
Depends: fontconfig, psmisc, debianutils (>= 1.16), libatk1.0-0 (>= 1.7.2), libc6 (>= 2.3.2.ds1-4), libfontconfig1 (>= 2.2.1), libfreetype6 (>= 2.1.5-1), libgcc1 (>= 1:3.4.1-3), libglib2.0-0 (>= 2.5.5), libgtk2.0-0 (>= 2.5.5), libidl0, libjpeg62, libkrb53 (>= 1.3.2), libpango1.0-0 (>= 1.6.0b), libpng12-0 (>= 1.2.7), libstdc++5 (>= 1:3.3.4-1), libx11-6 | xlibs (>> 4.1.0), libxft2 (>> 2.1.1), libxrender1, libxt6 | xlibs (>> 4.1.0), zlib1g (>= 1:1.2.1)
Recommends: mozilla-firefox-gnome-support (= 1.0-2ubuntu3), xprt-xprintorg
Suggests: latex-xft-fonts
Size: 9339972
Description: lightweight web browser based on Mozilla
Firefox is a redesign of the Mozilla browser component, similar to
Galeon, K-Meleon and Camino, but written using the XUL user interface
language and designed to be lightweight and cross-platform.
.
This browser was previously known as Firebird and Phoenix.

root@andy:/ #

andy caps
29-12-2004, 19:47
:madai!?: io sinceramente mi loggo sempre come root da debian ed ubuntu ma mi sembra strano questo gioco di password

Kamui
29-12-2004, 19:52
Ho queste di repository :zizi:


root@ubuntu:/etc/gdm # cat /etc/apt/sources.list|egrep -E ^deb
deb cdrom:[Ubuntu 4.10 _Warty Warthog_ - Preview i386 Binary-1 (20041020)]/ unstable main restricted
deb http://archive.ubuntu.com/ubuntu warty main restricted
deb http://archive.ubuntu.com/ubuntu warty universe

andy caps
29-12-2004, 19:58
deb http://archive.ubuntu.com/ubuntu/ warty universe
# deb-src http://archive.ubuntu.com/ubuntu/ warty universe

prova a mettere anche queste

io ho aggiornato ad hoary mettendo queste

deb http://archive.ubuntu.com/ubuntu/ hoary universe
deb-src http://archive.ubuntu.com/ubuntu/ hoary universe

deb http://archive.ubuntu.com/ubuntu/ hoary main restricted
deb-src http://archive.ubuntu.com/ubuntu/ hoary main restricted

c'è da tirare giu xserver e tutto kde per fare l'aggiornamento altrimenti da diversi errori

poi ho messo anche

deb ftp://ftp.nerim.net/debian-marillat/ unstable main

:madai!?: per mplayer

Loading