PDA

Visualizza la versione completa : [java]applet non si carica


..$maxxisi$..
31-12-2004, 17:06
Salve a tutti,
ho un problema con l'apertura degli appelet, quando carico il file html con dentro l'applet mi si visuallizza uno spazio grigio, e sotto,
mi apparate la scritta "caricamento Appelet Java non riuscito".
Sapete darmi un consiglio per caricare con successo l'appet??.
Grazie in anticipo e buone feste.

kerbero
01-01-2005, 10:54
Sei sicuro di aver dichiarato la classe dell'applet public?

netarrow
01-01-2005, 11:51
posta il code html

:ciauz: auguri!

..$maxxisi$..
02-01-2005, 12:34
Ciao, grazie per aver risposto, e tanti auguri di felice anno,
il codice html è il seguente :

<html>
<head>
<title>ciao lla mia città</title>
</head>
<h1>esempio di un applet</h1>


esempio di una pagina web con applet</p>
<applet code="C:\Documenti\massi\ling_pro\p_java\appletSaluto.tx t\" width=150 height=25>
</applet>
</body>
</html>
e questo è il codice dell'applett:


import java.awt.Graphics;
public class AppletSaluto extends java.applet.Applet {
public void paint(Graphics g) {
g.drawString("Ciao alla mia citt…!", 5, 25);
}
}
:ciauz: grazie

DYNAM!C+
02-01-2005, 13:08
<html>
<head>
<title>ciao lla mia città</title>
</head>

<body>
<h1>esempio di un applet</h1>


esempio di una pagina web con applet</p>

<applet codebase="C:\Documenti\massi\ling_pro\p_java" code="appletSaluto.class" width="150" height="25"></applet>
</body>
</html>


if file "appletSaluto.java" (mi pare abbia estensione .txt adesso) va compilato con JAVAC.EXE

netarrow
02-01-2005, 13:40
se non l'hai fatto scarica la JDK (http://192.18.97.222/ECom/EComTicketServlet/BEGIN652A4AE1A7B1C0CE5218AFDD5D9FE6A5/-2147483648/675043851/1/538238/538070/675043851/2ts+/westCoastFSEND/j2sdk-1.4.2_06-oth-JPR/j2sdk-1.4.2_06-oth-JPR:14/j2sdk-1_4_2_06-windows-i586-p-iftw.exe). E' un file eseguibile da 356 kb, però mentre fai l'installazione devi essere connesso, è più pratico che scaricare il setup da 51 Mega per l'off-line installation.

Inoltre per lavorare con comodità in Java ci vuole un IDE, io uso Eclipse (http://www.eclipse.org), ho la versione 3.0, inoltre puoi installare dei plugin per semplificare il lavoro come la possibilità di disegnare le applet e le altre applicazioni, ma ti consiglio di usare l'Eclipse di default così sei costretto a scrivere tutto tu e a fare pratica.

ciao :ciauz:

..$maxxisi$..
02-01-2005, 15:40
Grazie ora funziona!
Vi ringrazio anche per i consigli!
Ciao!
:ciauz:

Loading