PDA

Visualizza la versione completa : [Suse 9.1 pro] Abilitare MySql (installato di default)


nicaragua90
01-01-2005, 09:57
Ho appena installato suse 9.1 pro
nell'installazione ho scelto di "installare" apache php e mysql i primi due partono ma come avvio mysql e come imposto host user e pass?
ho provato attraverso yast abilitando mysql nell'editor dei runlevel ( l'unico riferimento a mysql che ho trovato in yast) ma ottengo questo inevitabile errore

/etc/init.d/mysql start ha restituito 1 (Errore non meglio specificato)
Creating MySQL privilege database and starting MySQL...
hostname: Unknown host
Neither host '' and 'localhost' could not be looked up with
/usr/bin/resolveip
Please configure the 'hostname' command to return a correct hostname.
If you want to solve this at a later stage, restart this script with
the --force option
..failed

Come devo fare
Grazie e buon anno

alex86
01-01-2005, 10:03
fai una ricerca sui tanti post che spiegano come configurare apache!..credo ti basti creare l'utente mysql (con relativa cartella in /home) e poi loggarti con questo utente e lanciare mysql start da /etc/init.d/

:ciauz:

francofait
01-01-2005, 10:10
yast2 - editor dei runlevel

alex86
01-01-2005, 10:14
Originariamente inviato da francofait
yast2 - editor dei runlevel

per farlo partire in automatico..ma credo sia molto sconsigliato..

1. rallenta il sistema (e mi sembra normale)
2. Lascia molte porte aperte...nn una buona cosa :D

comunque credo che se non lo configura prima non parta..poi non s..io ho seguito la guida di lamp per metterlo sulla 9.2.. :ciauz:

francofait
01-01-2005, 10:20
Originariamente inviato da alex86
per farlo partire in automatico..ma credo sia molto sconsigliato..

1. rallenta il sistema (e mi sembra normale)
2. Lascia molte porte aperte...nn una buona cosa :D

comunque credo che se non lo configura prima non parta..poi non s..io ho seguito la guida di lamp per metterlo sulla 9.2.. :ciauz:

Per configurare il tutto , webmin

nicaragua90
01-01-2005, 11:23
innanzitutto grazie a tutti per l'aiuto,innanzitutto volevo precisare che l'errore lo ottengo proprio andando ad abilitare mysql nell'editor dei runlevel, poi volevo chiedere dov' webmin?

alex86
01-01-2005, 11:36
prova a dare sti comandi da root

useradd mysql
mkdir /home/mysql
su mysql
cd /etc/init.d/
./mysql start

ah dimenticavo..webmin se non l'hai installato lo trovi su un cd della suse..da yast cercalo e lo installi!.. un buon programma per la gestione del db..potresti anche provare phpmyadmin che davvero ottimo! :ciauz:

nicaragua90
01-01-2005, 14:25
Risopondo
ho installato webmin ed in esecuzione ma se digito http://127.0.0.1:10000 ottengo:
Si verificato un errore durante il caricamento di http://127.0.0.1:10000:
Impossibile connettersi all'host 127.0.0.1 (porta 10000)
ho provato ad aggiungere l'utente mysql ma mi dice che gia esiste.

se invece digito mysql start mi da sempre lo stesso errore
con phpmyadmin invece:

Messaggio di MySQL:
#2002 - Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

sto impazzendo, con winxp usavo mysqladmin per impostare host, nome utente e password ma con linux non so proprio come fare. aiutooo

francofait
01-01-2005, 14:37
Originariamente inviato da nicaragua90
Risopondo
ho installato webmin ed in esecuzione ma se digito http://127.0.0.1:10000 ottengo:
Si verificato un errore durante il caricamento di http://127.0.0.1:10000:
Impossibile connettersi all'host 127.0.0.1 (porta 10000)
ho provato ad aggiungere l'utente mysql ma mi dice che gia esiste.

se invece digito mysql start mi da sempre lo stesso errore
con phpmyadmin invece:

Messaggio di MySQL:
#2002 - Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

sto impazzendo, con winxp usavo mysqladmin per impostare host, nome utente e password ma con linux non so proprio come fare. aiutooo

Non vedo come si possano passare indirizzi senza prima eseguire la configurazione.


http://localhost:10000

root e password x attivare webmin , poi ti configuri il tutto in funzione delle tue esigenze

alex86
01-01-2005, 15:19
ma lo lanci dall'utente mysql?fai una ricerca per sto sock che l'ho visto un sacco di volte postato e sempre risolto!

comunque non capisco il perch del 10000!..nn lo mettere ke uguale

Loading