PDA

Visualizza la versione completa : bootloader


mossetto
01-01-2005, 22:20
Ciao a tutti,dunque: io ho due hard disk sul pc nel primo ho win98se sul secondo mdk 10.0, ora avrei voluto installare ubuntu sullo spazio libero del secondo hd, ho creato una partizione di 5gb in / (hdc3)e tutto sembrava ok ma quando sono arrivato a installare grub e gli ho detto di metterlo in /dev/hdc3 mi da errore. pure lilo la stessa cosa.

ma non funzionava che il nuovo bootloader devo montarlo sulla partizione del suo s.o. per poi modificare lilo di mdk gi nel mbr... ma non me lo lascia fare !!!???

ora io ho terminato ugualmente l'installazione di ubuntu regolarmente ma senza installare il bootloader e ora ciccio le dita per far partire ubuntu??? :messner: :messner: :messner:

francofait
01-01-2005, 22:44
Originariamente inviato da mossetto
Ciao a tutti,dunque: io ho due hard disk sul pc nel primo ho win98se sul secondo mdk 10.0, ora avrei voluto installare ubuntu sullo spazio libero del secondo hd, ho creato una partizione di 5gb in / (hdc3)e tutto sembrava ok ma quando sono arrivato a installare grub e gli ho detto di metterlo in /dev/hdc3 mi da errore. pure lilo la stessa cosa.

ma non funzionava che il nuovo bootloader devo montarlo sulla partizione del suo s.o. per poi modificare lilo di mdk gi nel mbr... ma non me lo lascia fare !!!???

ora io ho terminato ugualmente l'installazione di ubuntu regolarmente ma senza installare il bootloader e ora ciccio le dita per far partire ubuntu??? :messner: :messner: :messner:

no fai partire la distro madre del bootloader , aggiorni il suo /etc/fstab includendoci la partiz. Ubuntu crei in suo punto di mount e la monti
Poi da /boot di ubuntu prendi vmlinuz ed initrd ubuntu ,e ne fai una copia in /boot della distro in uso .
A questo punto editi lilo.conf e lo aggiorni utilizzando in questo caso la funzione ' image '

mossetto
01-01-2005, 22:48
grazie, fra un momento ci provo...anche se non so cosa la funzione image

francofait
01-01-2005, 23:02
Originariamente inviato da mossetto
grazie, fra un momento ci provo...anche se non so cosa la funzione image

image = /boot/vmlinuz....estensione completa del kernel ospite
root= /dev/hdc3 (la tua ubuntu se non erro)
append=" eventuali funzioni append se necessarie x il corretto avvio "
initrd=/boot/initrd....estensione completa di initrd ospite
read-only

:ciauz: :ciauz: :ciauz:

mossetto
03-01-2005, 23:01
ciao, ho potuto provare solo ora, sono riuscito a fare come mi ha spiegato sopra ma non ho inserito la riga append perch le eventuali funzioni per il corretto avvio non le conosco !!! copio pari pari la riga append riguardante mdk ???

francofait
03-01-2005, 23:05
Originariamente inviato da mossetto
ciao, ho potuto provare solo ora, sono riuscito a fare come mi ha spiegato sopra ma non ho inserito la riga append perch le eventuali funzioni per il corretto avvio non le conosco !!! copio pari pari la riga append riguardante mdk ???

postale che te lo dico , comunque in linea di massima , dovrebbero andare.

Un'altra cosa per il kernel ospite usa vmlinux ed initrd completi di tutta la loro estensione non eseguire copie dei link simbolici .

mossetto
04-01-2005, 00:02
ecco qui :

boot=/dev/hda
map=/boot/map
default="linux"
keytable=/boot/it-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hdc1
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hdc5"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hdc1
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hdc5 devfs=nomount"
read-only
image=/boot/vmlinuz-2.6.8.1-3-386
label="ubuntu"
root=/dev/hdc3
initrd=/boot/initrd.img-2.6.8.1-3-386
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe
intanto grazie per l'aiuto, ci ho messo un p perch devo sempre collegarmi con windows visto che non riesco a far andare il mio modem usb thundercom con linux...non che magari risolvi pure questo !!!
:ciauz:

francofait
04-01-2005, 02:21
Originariamente inviato da mossetto
ecco qui :

boot=/dev/hda
map=/boot/map
default="linux"
keytable=/boot/it-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hdc1
initrd=/boot/initrd.img
append="devfs=mount acpi=ht resume=/dev/hdc5"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hdc1
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hdc5 devfs=nomount"
read-only
image=/boot/vmlinuz-2.6.8.1-3-386
label="ubuntu"
root=/dev/hdc3
initrd=/boot/initrd.img-2.6.8.1-3-386
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe
intanto grazie per l'aiuto, ci ho messo un p perch devo sempre collegarmi con windows visto che non riesco a far andare il mio modem usb thundercom con linux...non che magari risolvi pure questo !!!
:ciauz:

append="devfs=mount acpi=on apm=off resume=/dev/hdc5"

mettilo in questo modo - se dovesse darti qualche problema lo spengimento del monitor aggiungici : acpi=force

ora con la partiz. ubuntu montata , da console dai :

lilo -v

per riaggiornare il bootloader

Per quanto riguarda il modem , che chipset utilizza ?

mossetto
04-01-2005, 23:08
grazie fra un p provo... per il modem io ho provato a smontarlo ma sulla schedina i componenti hanno solo sigle numeriche come faccio a sapere il produttore ?

mossetto
08-01-2005, 21:44
da una ricerca su internet risulta che il mio modem dovrebbe avere chipset ROCKWELL... che dici...?

Loading