PDA

Visualizza la versione completa : Problemi con PAM


shishii
03-01-2005, 18:41
Ciao a tutti,

con questa configurazione:

server cobalt RAQ2 CPU mips
distro Debian sarge

accessibile da console SOLO tramite ssh, in quanto non ha tastiera, monitor, ne altro a parte una porta di rete ed una seriale.

effettuo l'autenticazione tramite PAM.

Il file di configurazione per ssh è:


# PAM configuration for the Secure Shell service

# Disallow non-root logins when /etc/nologin exists.
auth required pam_nologin.so

# Read environment variables from /etc/environment and
# /etc/security/pam_env.conf.
auth required pam_env.so # [1]

# Standard Un*x authentication.
@include common-auth

# Standard Un*x authorization.
@include common-account

# Standard Un*x session setup and teardown.
@include common-session

# Print the message of the day upon successful login.
session optional pam_motd.so debug # [1]

# Print the status of the user's mailbox upon successful login.
session optional pam_mail.so debug standard noenv # [1]

# Lastlog
session optional pam_lastlog.so debug

# Set up user limits from /etc/security/limits.conf.
session required pam_limits.so

# mia aggiunta
session required pam_chroot.so

# Standard Un*x password updating.
@include common-password


succede che tutti i moduli con control flag "option" vengono completamente ignorati. Dico che sono ignorati perchè oltre a non vedere gli effetti (la stampa del last login, il banner e se l'utente ha mail o no) non c'è traccia nei files di log della esecuzione di questi moduli, neanche settando ssh con debug3. Non è neanche un problema legato alla posizione in quanto gli ultimi due vengono eseguiti.

di cosa si potrebbe trattare?

shishii
04-01-2005, 10:48
up :D

Loading