PDA

Visualizza la versione completa : tasto centrale mouse


alx815
04-01-2005, 13:20
Rag ho questo pseudo problema (pseudo xch anche se nn riesco a risolverlo nn mi tocca + di tanto), ho un mouse della trust wireless, un ami 250series. sta su ps2 e nn riesco a configurarlo ottimamente... mi spiego, dato che il mouse ha 5 tasti nn trovo alcuna configurazione perfettamente funzionante. al momento funge tutto (anche lo scroller) tranne il terzo tasto (quello appunto sotto la rotellina)... il tasto mi tornerebbe utile dato che navigo con mozilla (o firefox) e con quel tasto apro i link....qualcuno sa come risolvere????
thanks
By(t)e :ciauz:

NonnoBassotto
04-01-2005, 13:27
Usi Xfree o Xorg?
Comunque, apri il file di configurazione (di Xfree o di Xorg) e posta la sezione relativa al mouse (Section "InputDevice" - Identifier "Mouse" [per esempio]).

alx815
04-01-2005, 19:33
Scusa nonno ma nn riesco a capire cosa devo fare.... sono entrato da console in /dev/input/ ma del mouse nn che mi dice nulla, ci sono solo i comandi mouseconfig e mousedrake....
Anche dal pannello di configurazione grafico nulla, mi porta a configurare il mouse ma sempre la stessa cosa..... :bh:

Ps: uso (anzi ho, xch nn lo so usare :stordita: ) Xorg
By(t)e

NonnoBassotto
04-01-2005, 19:45
E' possibile che il mouse sia settato come un classico "5 tasti" (considerando che "rotellina su" e "rotellina gi" sono due tasti).
Allora, da "root", apri /etc/X11/xorg.conf, cerca la sezione che inizia con "InputDevice" e pasta qui la parte relativa a "Identifier Mouse1" o qualcosa del genere.

alx815
04-01-2005, 22:12
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection




Ecco quello la parte che mi hai chiesto, grazie x l'aiuto :ciauz:

NonnoBassotto
04-01-2005, 23:15
Mmmh... allora, prova cos:

1- Aggiungi, prima di "Option ZAxisMapping 4 5", la riga:

Option "Buttons" "7"
2- Rilancia X e vedi se cambia qualcosa. In caso contrario (quasi sicuramente):
3- Rimappa i tasti del mouse dando il comando:

/usr/X11R6/bin/xmodmap -e "pointer = 1 2 3 6 7 4 5"
4- Prova a vedere se gira tutto. Se le funzioni della rotellina sono sballate o invertite, prova a reimpostare xmodmap spostando il 4 e il 5 (sempre contigui, per)
5- Per vedere se i tasti sono almeno riconosciuti, lancia in console "xev" (senza le virgole) e dentro il quadrato premi uno alla volta i vari tasti del mouse. Per ognuno, dovrebbe comparire una serie di informazioni.
6- Se qualche tasto continua a non funzionare, forse ti conviene ricorrere a ImWheel (http://imwheel.sourceforge.net/)

Ciao!

alx815
07-01-2005, 18:22
Grazie, finelmente ho risolto :smack:

Loading