PDA

Visualizza la versione completa : [ReiserFS] Le partizioni non vengono montate (urgente)


innovatel
10-01-2005, 22:19
Allora, la situazione è tragica e non poco :(

Sabato pomeriggio ho partizionato il mio disco sata da 120gb in 4 partizioni di tipo ReiserFS.


/dev/sda1
/dev/sda2
/dev/sda3
/dev/sda4

Ho preso i miei dati e li ho copiati in base a ciò che mi serviva nella partizione che era più idonea allo scopo.

Prima di cancellare il disco dei dati ho fatto 300 mila controlli se avessi copiato tutto oppure no e una volta che ho avuto la certezza ho usato il disco "dati originale" per installarci i sistemi operativi.

Premetto che prima di fare le installazioni ho SCOLLEGATO fisicamente il SATA coi dati.

Stasera mi serviva un file contenuto in una di quelle partizioni, così ho deciso di collegarlo.

Collego, avvio ubuntu e faccio il mount e vedo che restà lì fermo ed immobile senza segnali di vita. A questo punto provo con una knoppix e mi dice
[quote]
Impossibile montare il dispositivo.
L'errore riportato è:
mount: tipo fs errato, opzione non valida, superblocco su /dev/sda1 danneggiato,
o troppi file system montati
[/code]
A questo punto ho cominciato a ravanare in rete e ho trovato come soluzione di lanciare reiserfsck per ricostruire l'albero. Lo farei molto volentieri, ma appena gli indico la partizione /dev/sda1 si inchioda e non dà segnali di vita.

Vedendo la situazione "dal nemico" mi riconosce il disco e approfittando del fatto che la /dev/sda4 fosse libera l'ho eliminata e gli ho detto di crearne una di tipologia NTFS. L'ha fatta e funziona per bene (anche linux la vede).

Peccato che a me interessano i dati delle altre 3 :(

Avete una minima idea di come potrei fare?

Come opzione stavo anche puntando a usare il diskdrake della mandrake per muovere di poco quelle 3 partizioni e vedere se riesco poi ad accerci

:cry: aiutate un piccolo inno in punto di suicidio :cry:

graziee :cry:

---

dimenticavo ... ora son con knoppix e la situazione è la stessa

alex86
10-01-2005, 22:29
quando lo colleghi ke ti dice dmesg?

andy caps
10-01-2005, 22:32
ma ubuntu è sul sata ?

altrimenti guarda di aver caricato i moduli per scsi

prova anche a montarla semplicmente

mount /dev/sda1 /mnt/sda1 senza indicare il fs

con l'ultimo mount non c'è piu bisogno del -t reiserfs

innovatel
10-01-2005, 22:33
le distro son tutte si IDE

il mount lo effettuo in quel modo :(

IroN@xiD
10-01-2005, 22:35
hai provato a specificare al comando mount che si tratta di una reiser?
Magari in automatico individua un fs sbagliato e quindi non lo monta.

Altra cosa, prova con uno dei tool per il nemico che riesca a visualizzare reiser. A me è successa una cosa simile e mentre mount non riusciva a combinare un tubo con un applicazione per winzoz sono riuscito a recuperare i dati.. :jam: :jam:

per il momento non mi viene altro in mente...

Good luck!!

:ciauz:

innovatel
10-01-2005, 23:06
:unz: Dati salvati :unz:

Io l'ho sempre detto che amerò quel ragazzo alla follia :sbav: :sbav:

Stò parlando di kain (www.kuht.it)

la mia salvezza (http://www.kuht.it/modules/newbb/viewtopic.php?topic_id=2188&forum=7)


i test per vedere come mai non rilevava le partizioni su linux li farò più avanti, ora mi interessa avere i dati in salvo (che è meglio)

Loading