PDA

Visualizza la versione completa : di tutto e di piu, ma il mio X ancora non parte (gentoo)


pauloref
11-01-2005, 20:32
Il mio X non parte. Io avevo gentoo partito da stage 3. Ho fatto un bootsrtap, emerge system, emerge -u --deep world. Ho ricompilato la mia machina da cima a fondo e ancora niente. Faccio startx. Appare il simbolo della nvidia, e poi scompare tutto e mi ritrovo di nuovi di nuovo su console. Vado a vedere con:
cat /var/log/Xorg.0.log
e l'errore e:

No core keyboard

Fatal server error:
failed to initialize core devices

:cry: :cry:

che cosa devo farre? :dh: :dh: :dh:

NonnoBassotto
11-01-2005, 20:38
Controlla che in /etc/X11/xorg.conf, alla voce
Section "InputDevice"
Identifier "Keyboard1" (o quello che hai messo)

ci sia Driver "kbd"

pauloref
11-01-2005, 20:48
si, c'e

NonnoBassotto
11-01-2005, 21:21
Posta qualche riga in pi, dal log.

pauloref
11-01-2005, 21:42
ecco qualche riga in piu:


(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "Protocol" "IMPS/2"
(**) Mouse1: Device: "/dev/psaux"
(**) Mouse1: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons"
(**) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse1: ZAxisMapping: buttons 4 and 5
(**) Mouse1: Buttons: 5
(**) Mouse1: SmartScroll: 1
(EE) No Input driver matching `Keyboard'
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse1: ps2EnableDataReporting: succeeded
No core keyboard

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


alloa

NonnoBassotto
11-01-2005, 22:41
Come pensavo. Il problema qui:



...
(EE) No Input driver matching `Keyboard'
...


Cerca nel tuo xorg.conf il riferimento a quel "Keyboard" e metti invece
keyboard (con la "k" minuscola) oppure
kbd .

pauloref
11-01-2005, 23:03
ecco pezzi del mio xorg.conf:


# Core keyboard's InputDevice section
# ************************************************** ********************

Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

# Option "Protocol" "Xqueue"

Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# Option "LeftAlt" "Meta"
# Option "RightAlt" "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for Xorg

# Option "XkbModel" "pc101"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"


Option "XkbModel" "pc101"
Option "XkbLayout" "it"

EndSection


# ServerLayout sections.
# ************************************************** ********************

# Any number of ServerLayout sections may be present. Each describes
# the way multiple screens are organised. A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option. In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.

Section "ServerLayout"

# The Identifier line must be present
Identifier "Simple Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens. The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen. In this example, screen 2 is located to the
# right of screen 1.

Screen "Screen 1"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used. Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

# Section "DRI"
# Mode 0666
# EndSection

sembra tutto a posto?? que ne dici??

NonnoBassotto
11-01-2005, 23:11
E nel tuo xorg.conf non c' traccia di un driver chiamato "Keyboard" ? ...non capisco l'errore, allora...

pauloref
11-01-2005, 23:27
io non ho trovato nente che si chiami keyboard. E in piu ho provato a fare xorgconfig, ma non funziona lo stesso!!

Loading