PDA

Visualizza la versione completa : problema spam su postfix


loked
12-01-2005, 15:14
Salve a tutti,
uso postfix con amavis-new, clamav, e spamassassin , tutto chiamato da amavis-new
il clamav funziona egregiamente ma purtroppo amavis non mi blocca lo spam, se imposto la soglia a 0 me le blocca tutte, quindi il test lo fa , attualmente la soglia Ŕ impostata a 6

mi date qualche dritta?

grazie a tutti cmq per i numerosi aiuti ricevuti in passato
ciao

l.golinelli
12-01-2005, 20:21
Posta amavisd.conf :master:

loked
13-01-2005, 16:06
$sa_tag_level_deflt = 2.0;
$sa_tag2_level_deflt = 5.0;
$sa_dsn_cutoff_level = 10;
$sa_mail_body_size_limit = 150*1024;
$sa_local_tests_only = 0;
#$sa_auto_whitelist = 1;

credo che questa sia tutta la parte che riguarda lo spam, ed ho anche commentato la riga
# @bypass_spam_checks_maps = (1);
all'inizio del file.
ho passato con sa-learn una mail contenente spam, ma quando l'ho ricevuta di nuovo non la bloccava.

grazie per l'interessamento

l.golinelli
13-01-2005, 16:40
# SpamAssassin settings
$sa_local_tests_only = 0;
$sa_auto_whitelist = 0; # comment this line out to turn off auto whitelist
$sa_mail_body_size_limit = 64*1024; # 64KB

$sa_tag_level_deflt = 0.0; # controls adding the X-Spam-Status and X-Spam-Level headers,
$sa_tag2_level_deflt = 4.5; # controls adding 'X-Spam-Flag: YES', and editing Subject,
$sa_kill_level_deflt = 6.0; # triggers spam evasive actions:

$sa_spam_subject_tag = '**** SPAM **** ';
$sa_debug = 0; # comment this line out to turn off debugging

loked
13-01-2005, 16:51
Jan 13 16:49:13 mailserv postfix/smtpd[4725]: connect from unknown[10.20.10.79]
Jan 13 16:49:13 mailserv postfix/smtpd[4725]: 736E62D023F: client=unknown[IndirizzoIP]
Jan 13 16:49:13 mailserv postfix/cleanup[4733]: 736E62D023F: message-id=<012301c4f987$38fe5630$4f0a140a@priosa>
Jan 13 16:49:13 mailserv postfix/qmgr[4724]: 736E62D023F: from=<mittente>, size=5557, nrcpt=1 (queue active)
Jan 13 16:49:13 mailserv postfix/smtpd[4725]: disconnect from unknown[indirizzoIP]
Jan 13 16:49:14 mailserv postfix/smtpd[4739]: connect from mailserv[127.0.0.1]
Jan 13 16:49:14 mailserv postfix/smtpd[4739]: 038C72D026F: client=mailserv[127.0.0.1]
Jan 13 16:49:14 mailserv postfix/cleanup[4733]: 038C72D026F: message-id=<012301c4f987$38fe5630$4f0a140a@priosa>
Jan 13 16:49:14 mailserv postfix/qmgr[4724]: 038C72D026F: from=<mittente>, size=5994, nrcpt=1 (queue active)
Jan 13 16:49:14 mailserv amavis[4637]: (04637-01) Passed CLEAN, [IndirizzoIP] <mittente> -> <destinatario>, Message-ID: <012301c4f987$38fe5630$4f0a140a@priosa>, Hits: -1.286, 573 ms
Jan 13 16:49:14 mailserv postfix/smtpd[4739]: disconnect from mailserv[127.0.0.1]
Jan 13 16:49:14 mailserv postfix/smtp[4736]: 736E62D023F: to=<destinatario>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=04637-01, from MTA: 250 Ok: queued as 038C72D026F)
Jan 13 16:49:14 mailserv postfix/qmgr[4724]: 736E62D023F: removed
Jan 13 16:49:14 mailserv postfix/virtual[4744]: 038C72D026F: to=<destinatario>, relay=virtual, delay=0, status=sent (delivered to maildir)

loked
13-01-2005, 16:54
Gli ho mandato uno spam con questo test ed ho riavviato amavis-new prima di farlo.

loked
13-01-2005, 17:36
poi volevo chiederti un altra cosa io ho configurato spamassassin con il local.cf e l'ho istruito con il comando sa-learn --spam, ma perchŔ da amavis queste modifiche non vengono lette? centra qualcosa procmail? perchŔ io ho un file /etc/procmailrc con delle regole ma dal maillog non ne vedo traccia ne tantomeno da procmail.log che devo fÓ?? ci sto impazzendo per questo spam, il resto funziona alla grande.

cmq ti ringrazio per la disponibilitÓ
ciao

l.golinelli
13-01-2005, 19:24
In postfix hai specificato procmail per mettere la posta nelle caselle?

Da dove hai preso le mail da dare in pasto a sa-learn

Che ver hai di spamassassin?

loked
14-01-2005, 14:53
allora nel main.cf di postfix ho messo questa voce
mailbox_command = /usr/bin/procmail
ed ho messo in etc/procmailrc :

DROPPRIVS=yes
LOGFILE=/var/log/procmail.log
VERBOSE=yes
:0fw
* < 256000
#| spamc -f
| /usr/bin/spamassassin
:0:/tmp/spam.lock
*^X-Spam-Flag: YES
/var/spool/postfix/spam

ma non ho traccia di procmail sia nel maillog che in procmail.log, il che mi fa pensare che non parta proprio, puo essere?
Le mai date in pasto a sa-learn sono le mail che i miei utenti ricevono nella posta.
ho spamassassin 3.02

mi chiedevo una cosa io uso il formato maildir pu˛ essere che sia questo che crea problemi?
ed un altra cosa il demone spamd deve essere lanciato o amavis-new lancia da solo lo spamc?

loked
14-01-2005, 14:54
faccio girare tutto chroot ma non ho nessun messaggio di permission denied.

Loading