PDA

Visualizza la versione completa : [Fedora Core 3] Nuovo utente


Gionnico
17-01-2005, 23:16
Ho Fedora Core 3, ed ho dato il comando:

[root@localhost ~]# useradd me -p pass

Che mi ha dato in risposta

useradd: cannot rewrite password file

Cosa significa? Per ora ho solo l'utente di root, e non sono riuscito a crearne altri nè con il suo programmino, nè con il comando da terminale! :dhò:

Forse manca qualche pacchetto? :fagiano:
Non lo sò, mi aiutate? :nonlodire

Gionnico
18-01-2005, 18:00
up

alkat
18-01-2005, 18:37
don't know if this can help:

http://linux.derkeiler.com/Mailing-Lists/Fedora/2004-06/8094.html

giusto per aggirare il problema,
hai provato con adduser?

http://www.linuxheadquarters.com/howto/basic/adduser.shtml

Gionnico
19-01-2005, 14:04
Originariamente inviato da alkat
don't know if this can help:

http://linux.derkeiler.com/Mailing-Lists/Fedora/2004-06/8094.html

Già, proprio quello, ma nessuno gli ha risposto...


Originariamente inviato da alkat
giusto per aggirare il problema,
hai provato con adduser?

http://www.linuxheadquarters.com/howto/basic/adduser.shtml
Si, ho provato, stesso errore.

Mi chiedo se la sintassi è giusta o sufficiente:

useradd -p mypass gionnico :(

andy caps
19-01-2005, 14:11
prova alla maniera gentoo


Codice 18.2: Aggiungere un utente

# useradd vostro_utente -m -G users,wheel,audio -s /bin/bash
# passwd vostro_utente

Gionnico
21-01-2005, 19:14
Originally posted by Andy Caps
Prova alla maniera gentoo:


# useradd vostro_utente -m -G users,wheel,audio -s /bin/bash
# passwd vostro_utente



Ho provato:


[root@localhost ~]# useradd gionnico -m -G users,wheel,audio -s /bin/bash
useradd: unknown group audio

Non ha funzionato.


[root@localhost ~]# passwd gionnico
bash: passwd: command not found
[root@localhost ~]#

Non ha funzionato, ma non perché non ha trovato l'utente, bensì perché non ha riconosciuto il comando "passwd".

Help, plz! :cry:

andy caps
21-01-2005, 20:59
:bhò: a me lo riconosce probabilmente non hai installato il pacchetto

installalo il pacchetto si chiama appunto

passwd


passwd - The passwd utility for setting/changing passwords using PAM.

Ikitt
21-01-2005, 21:03
Originariamente inviato da Gionnico
Non ha funzionato, ma non perché non ha trovato l'utente, bensì perché non ha riconosciuto il comando "passwd".


hai usato


su

oppure


su -

o qualcos'altro ancora per ottenere privilegi di root?

Gionnico
22-01-2005, 15:00
Originariamente inviato da andy caps
:bhò: a me lo riconosce probabilmente non hai installato il pacchetto

installalo il pacchetto si chiama appunto

passwd


passwd - The passwd utility for setting/changing passwords using PAM.
Siccome non ho il modem adatto per linux, mi dici dove lo trovo per scaricarlo da windows, e poi installarlo?


Ikitt
Hai usato su o su - per avere privilegi di root?

Se avessi letto il messaggio avresti visto l'#, e poi ho detto che l'unico utente che ho è root!

Ikitt
22-01-2005, 15:21
Originariamente inviato da Gionnico
Se avessi letto il messaggio avresti visto l'#, e poi ho detto che l'unico utente che ho è root!
Se avessi letto meglio il mio messaggio, avresti capito che la domanda non era sul se ma sul come hai ottenuto i privilegi di root.

Il fatto che passwd non sia un comando riconosciuto e` indice di solito di problemi di path, che a loro volta di solito derivano da un'uso [parzialmente] incorretto di su, da li la mia domanda.

Dato che ti logghi direttamente come root (questo mi era sfuggito, effettivamente), verifica che /sbin e /usr/sbin siano nel PATH e che passwd sia installato. Se ambedue le verifiche hanno esito positivo e` un discreto casino.

Loading