PDA

Visualizza la versione completa : Configurazione vsftpd


teazzo
18-01-2005, 10:54
Ciao, ho installato vsftpd su linux enterprise server WS, ma non riesco a configurarlo, quando mi connetto ricevo un errore "could not bind listening IPv4 socket"

makuro
18-01-2005, 11:25
la butti li...hai i permessi per creare un socket in ascolto sul server?

teazzo
18-01-2005, 11:26
Ciao, non lo so, come faccio a vederlo? Sono loggato come root

gigyz
18-01-2005, 11:46
scusa ma come lo hai installato ? fagliemo lanciare tramite inetd/xinetd

teazzo
18-01-2005, 14:21
S, l'ho fatto lanciare tramite xinetd, adesso mi connette ma funziona solo il login anonimo, usando gli utenti che ho creato non connette (dice login incorrect).

Il file di configurazione di vsftpd questo:

anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog format
xferlog_std_format=YES
pam_service_name=vsftpd
userlist_enable=YES
#listen=YES
#tcp_wrappers=YES

gigyz
18-01-2005, 15:35
da man vsftpd.conf:

userlist_enable
If enabled, vsftpd will load a list of usernames, from the filename given by userlist_file. If a user tries to log in using a name in
this file, they will be denied before they are asked for a password. This may be useful in preventing cleartext passwords being transmit-
ted. See also userlist_deny.

e non mi sembra di vedere anche l'opzione userlist_file, poi vedo che c' un'opzione relativa a PAM, il che implica che devi configurare anche PAM.

teazzo
18-01-2005, 16:58
Grazie mille, funziona, ho tolto il riferimento a pam e a userlist_file.

Loading