PDA

Visualizza la versione completa : [cgi-bin]Problema sottocartelle


Dodo84
25-01-2005, 13:15
sono giorni che sto impazzendo per fare andare cgi su un server Apache/fedora

alla fine sono riuscito farli funzionare normalmente cio come
www.miodominio.it/cgi-bin/test.cgi

ma se creo una sottocartella in cgi-bin, non riesco ad eseguire gli script nella sottocartella

www.miodominio.it/cgi-bin/test/test.cgi
mi da Internal Server Error

non capisco che altro devo fare :cry:

shishii
25-01-2005, 16:22
Devi verificare che la sotto cartella abbia i chmod giusti (755) e che la configurazione in httpd.conf non la escluda.

Dodo84
25-01-2005, 17:30
ciao grazie per la risposta,
allora il chmode settato giusto, quindi presumo che sia qualche configurazione dell'httpd.conf..

che stringa devo trovare per verificare se sia esclusa o meno?

scusa ma non sono molto esperto :dh: :master: :dh:

shishii
25-01-2005, 17:53
dovresti trovare

ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"
e
<Directory "/var/www/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

controlla che i path corrispondano con i tuoi, ma se una fedora dovrebbero andare bene.

Ti ribadisco comunque di verificare TUTTI i chmod delle directory a cominciare dall'inizio del path e devono essere 755 e NON ad esempio 775.

Dodo84
26-01-2005, 18:05
grandissimo risolto!
ineffetti avevi ragione i permessi non erano settati bene!

Ma il problem principale che non erano stati Uppati in maniera corretta!! :incupito:

grazie ancora!!

Loading