PDA

Visualizza la versione completa : lan: cosa sbaglio?


19semplicemente
03-02-2005, 11:16
a casa ho una lan configurata così:


http://www.webalice.it/a_denobi/Immagine.JPG

il PC1
è quello sempre connesso ad internet
ed è configurato così:
IP: 192.168.0.1
Subnet mask: 255.255.255.0

il PC 2
è quello che vorrei far andare in internet
è configurato così:
IP: 192.168.0.2
Subnet mask: 255.255.255.0
Gatway: 192.168.0.1

i due si "vedono" nel senso che riesco a trasferire file da un pc all'altro.. però.. il PC 2 non ne vuole sapere di andare in internet!!


s.o: windows xp con il sp2
antivirus: AVAST!
firewall: Sygate 5.6

nella firewall ho cercato di settare un "advanced rule" dicendo di permettere tutto il traffico in entrata e uscita, devo settare altro?
nn ho più idee...

help!

alexdem24
03-02-2005, 14:11
prima di tutto prova a disabilitare il firewall e vedi se cosi' funziona, seconda cosa verifica che il pc2 possa pingare il modem.

Spiegami un paio di cose..
xche' nel pc 2 metti come gateway il pc1 ?
se il modem e connesso allo switch ed entrambi i pc sono connessi direttamente allo switch, ad ogniuno di loro devi assegnare come gateway l'indirizzo del modem !!

Se il modem ha indirizzo 192.168.0.x
PC1 e PC2 devono avere come gateway 192.168.0.x.

ciao
fammi sapere

19semplicemente
03-02-2005, 15:15
ho risolto mettendo nel DNS del PC2 l'IP del PC1 :)

alexdem24
03-02-2005, 15:18
bravo.. la cosa importante in un problema e' trovare la soluzione per ottenere cio che si vuole.. Ma adesso pensiamo alle conseguenze.

Cosa succede se il tuo PC1 si spegne per qualche ragione ? oppure ha problemi di qualsiasi tipo ?

19semplicemente
03-02-2005, 15:22
buona notte a internet :(

alexdem24
03-02-2005, 15:26
ebravo infatti... e' l'architettura che e' sbagliata.

Come ti ho scritto prima, se dai, per ogni computer della tua rete connesso direttamente al router, come gateway l'indirizzo ip del tuo modem, ed assegni i dns corretti tutto funziona alla grande !!

provare per credere !

19semplicemente
03-02-2005, 15:30
come faccio a vedere l'ip dello switch? e funziona anche senza il rputer?

Etilico
03-02-2005, 15:51
lo switch non ha IP! devi trovare l'IP del modem ma non so come puoi fare per scoprirlo...

Arks
05-02-2005, 13:16
19-seguo questa discussione perche' tra un po' tocchera' a me, ma vorrei sapere che ne e' del firewall.
Lo sai che nell'Help di Sygate sotto il + di Troubleshooting ci sono istruzioni per ICS e Networking circa i permessi da accordare per un corretto funzionamento.

DefQon 1
05-02-2005, 13:41
io avevo il tuo problema ma con la wireless..uguale!!

cmq xchè nn abiliti il DHCP?? così gli indizzi sono assegnati automaticamente...e scopri qual'è l'indizzo ip del router.

io ho fatto così sia sulla lan che sul wireless...

Loading