PDA

Visualizza la versione completa : impossibile utilizzare driver ATI


nik600
05-02-2005, 19:50
ciao

scusate il titolo drastico, ho combinato una cazzata :fagiano:

in pratica ho sovrascritto il file xorg.conf con un file errato, ora anche se il modulo fglrx viene caricato correttamente X non vuole saperne di partire

ho provato a rilanciare lo script fglrxconfig che crea il vecchio XFREE86config (con il quale si sovrascrive xorg.conf) ma non ce verso di creare uno script che funzioni!

il server X va sempre in crash!

cosa posso fare secondo voi? ho gia provato a disinstallare e reinstallare il modulo, ho provato anche a ricompilare il kernel senza nessun risultato

cosa posso fare?

grazie nik

nik600
05-02-2005, 20:45
posto l'ultimo pezzo di xorg.log





[34] -1 0 0x00003000 - 0x000030ff (0x100) IX[B](B)

[35] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]

[36] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]

(II) fglrx(0): UMM area: 0xd8501000 (size=0x03aff000)

Symbol fbGetWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

Symbol XAAGetPixmapIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol fbGetWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

Symbol XAAGetPixmapIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o

is unresolved!

Symbol noCompositeExtension from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

Symbol noCompositeExtension from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!



*** If unresolved symbols were reported above, they might not

*** be the reason for the server aborting.



Fatal server error:

Caught signal 11. Server aborting





Please consult the The X.Org Foundation support

at http://wiki.X.Org

for help.

Please also check the log file at "/var/log/Xorg.0.log" for additional information.

nik600
05-02-2005, 22:19
ciao

ho risolto mettendo xorg 6.8.1 e modificando il device della tastiera in "kbd" al posto di "keyboard"

il problema che non c' verso di fare andare l'accelerazione grafica!

consigli?

nik600
06-02-2005, 11:23
le ho provate tutte

stamattina ho formattato :jam:

ho rimesso il kernel 2.6.8

ho compilato i driver e li carico al boot:



fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 429 MBytes.
ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 10 (level, low) -> IRQ 10
[fglrx] module loaded - fglrx 3.14.1 [Sep 27 2004] on minor 0



con lo script fglxrconfig ho ricreato il file XFREE86confing che ho rinominato in xorg.conf

ma x NON parte! :dh:

e da il seguente errore:



(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="X.Org Foundation"
compiled for 6.7.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"
(WW) Warning, couldn't open module fglrx
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (module does not exist, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
compiled for 6.7.0, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(EE) No drivers available.

Fatal server error:
no screens found

Loading