PDA

Visualizza la versione completa : X server non va più


snowboarder
09-02-2005, 14:52
oggi all'avvio di linux ho avuto una brutta sorpesa...

"I can't not start the X server (your...)
It is not set up correctly.Would you like to view the X server out put to diagnose the problem"

allora l'ho seguito e sono entrato in modalità testuale.
Con il startx ho provato a riavviare ma chiaramente non mi è andato e mi ha restituito una serie di errori dove mi riportava ad un file di log che io ho copiato:
(Il file l'ho ridotto parecchio causa spazio.La parte relativa all'errore è in fondo)

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present

OS Kernel: Linux version 2.4.18-24.8.0 (bhcompile@tweety.devel.redhat.com) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Fri Jan 31 06:51:30 EST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Feb 9 14:01:15 2005
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Anaconda Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "NVIDIA GeForce 2 MX (generic)"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc102"
(**) XKB: model: "pc102"
(**) Option "XkbLayout" "it"
(**) XKB: layout: "it"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.5
XFree86 XInput driver : 0.3
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.3
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80000090, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,1a30 card 8086,1a30 rev 04 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,1a31 card 0000,0000 rev 04 class 06,04,00 hdr 01
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev 05 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,2440 card 0000,0000 rev 05 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,244b card 8086,2442 rev 05 class 01,01,80 hdr 00
(II) PCI: 00:1f:2: chip 8086,2442 card 8086,2442 rev 05 class 0c,03,00 hdr 00
(II) PCI: 00:1f:4: chip 8086,2444 card 8086,2442 rev 05 class 0c,03,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0110 card 0000,0000 rev b2 class 03,00,00 hdr 00
(II) PCI: 02:0a:0: chip 14f1,2f00 card 14f1,2004 rev 01 class 07,80,00 hdr 00
(II) PCI: 02:0b:0: chip 1274,5880 card 1274,2000 rev 02 class 04,01,00 hdr 00
(II) PCI: 02:0c:0: chip 10b7,9055 card 10b7,9055 rev 64 class 02,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0e (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xec000000 - 0xedffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0xe0000000 - 0xe7ffffff (0x8000000) MX[B]
(II) Bus 2: bridge is at (0:30:0), (0,2,2), BCTRL: 0x06 (VGA_EN is cleared)
(II) Bus 2 I/O range:
[0] -1 0x0000c000 - 0x0000c0ff (0x100) IX[B]
[1] -1 0x0000c400 - 0x0000c4ff (0x100) IX[B]
[2] -1 0x0000c800 - 0x0000c8ff (0x100) IX[B]
[3] -1 0x0000cc00 - 0x0000ccff (0x100) IX[B]
(II) Bus 2 non-prefetchable memory range:
[0] -1 0xee000000 - 0xefffffff (0x2000000) MX[B]
(II) Bus 2 prefetchable memory range:
(II) Bus -1: bridge is at (0:31:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia GeForce2 MX/MX 400 rev 178, Mem @ 0xec000000/24, 0xe0000000/27


(II) NV(0): Modeline "800x600" 56.30 800 832 896 1048 600 601 604 631 +hsync +vsync
(**) NV(0): Default mode "640x480": 36.0 MHz, 43.3 kHz, 85.0 Hz
(II) NV(0): Modeline "640x480" 36.00 640 696 752 832 480 481 484 509 -hsync -vsync
(--) NV(0): Display dimensions: (280, 210) mm
(--) NV(0): DPI set to (72, 72)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.5
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.

(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(**) Option "Protocol" "PS/2"
(**) Mouse0: Protocol: "PS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(**) Option "Protocol" "IMPS/2"
(**) Mouse1: Protocol: "IMPS/2"
(**) Option "SendCoreEvents"
(**) Mouse1: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse1: ZAxisMapping: buttons 4 and 5
(**) Mouse1: Buttons: 5
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
Could not init font path element unix/:7100, removing from list!

Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.



Chiaramente non ci capisco nulla.
Io uso Red Hat 8.0.
Qualcuno sa dirmi cosa è successo?

side-server
09-02-2005, 14:54
Fatal server error:
could not open default font 'fixed'

non trova il font chiamato Fixed, prova a riconfigurare xfree con xf86config

:ciauz:

snowboarder
09-02-2005, 15:05
cioè?

snowboarder
09-02-2005, 15:15
cioè vorrei sapere cosa devo sostituire o settare dentro a xf86config? :confused:

andy caps
09-02-2005, 15:19
prova a commentare

#FontPath "unix/:7100"

ad esempio
se hai fatto aggiornamenti in alcuni casi bisogna mettere #FontPath "unix/:7110"

o lancia xf86config che ti ricrea il file da zero

snowboarder
09-02-2005, 15:24
dove devo mettere
#FontPath "unix/:7110" ?

andy caps
09-02-2005, 15:31
nel file di conf di X11

/etc/X11/XF86Config mi sembra con redhat

ma togli il commento

FontPath "unix/:7110"

se non va commentali entrambi ###


se hai la possibilta di incollarci questo pezzo dovresti risolvere

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

snowboarder
09-02-2005, 15:42
devo incollarlo sotto
Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these ?

andy caps
09-02-2005, 16:42
deve essere tutto compreso nell section

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection


altrimenti lancia il comando xf86config e rifai la configurazione

Loading