PDA

Visualizza la versione completa : Dipendenza e firma in pacchetto rpm


Nunkij
09-02-2005, 19:00
Salve a tutti.
Sono un linuxiano da due giorni e uso la red hat 9. Volevo un aiuto per l'installazione di un pacchetto rpm. Si tratta di gaim.

Scarico il file: gaim-1.1.2-0rh9.i386.rpm e da terminale eseguo rpm -i gaim-1.1.2-0rh9.i386.rpm (non so se il comando quello giusto, sono un principiantissimo).

Ricevo questo errore:

warning: gaim-1.1.2-0rh9.i386.rpm: V3 DSA signature: NOKEY, key ID 883c1c14
error: Failed dependencies:
libgtkspell.so.0 is needed by gaim-1.1.2-0rh9


a quanto capisco manca qualcosa ma non so cosa sia una dipendenza n tanto meno una firma. Mi date una mano? per favore siate quanto + chiari possibile, come potete immaginre non ne capisco davvero nulla. Grazie mille dell'aiuto.

Kandalf
09-02-2005, 19:02
volevi sapere qualcosa?
:confused:

nickcrazy
09-02-2005, 20:24
Anch'io sono poco esperto di linux, comunque devi sapere che per installare i vari programmi su linux, a meno che non si usino dei modi che singole distribuzioni mettono a disposizione per soddisfare le dipendenze (vedi urpmi x mandrake, apt-get x debian e derivati, yast x suse etc), il pi delle volte necessario avere gi installati degli altri programmi o il pi delle volte librerie (come mi sembra nel tuo caso), nel tuo caso mi sembra che ti manchi la libreria (lib sta appunto x libreria) gtkspell, anche se non ho mai capito perch compare alla fine l'estensione.so.0, che complica la ricerca dei pacchetti. Per quanto riguarda la signature key non ho mai neanche io mai capito bene a cosa serve, forse per identificare in modo sicuro il pacchetto da installare, ma non penso sia fondamentale :bh:

Nunkij
10-02-2005, 19:16
Ma alla fine cosa devo fare? Devo scaricare qualcosa? Da dove? Mi date un link x trovare sta roba? grazie mille!

pazx
10-02-2005, 19:24
Originariamente inviato da Nunkij
Salve a tutti.
....
Ricevo questo errore:

warning: gaim-1.1.2-0rh9.i386.rpm: V3 DSA signature: NOKEY, key ID 883c1c14
error: Failed dependencies:
libgtkspell.so.0 is needed by gaim-1.1.2-0rh9
...


dal sito di Gaim:
FAQ - Gaim (http://gaim.sourceforge.net/faq.php#q3)

Loading