PDA

Visualizza la versione completa : grub error 17


iacchi
12-02-2005, 12:14
Ciao a tutti. Ho finito ora di fare un'installazione su hd di kanotix (una knoppix-like basata sulla sid), e quindi preparatevi perché vi tempesterò di domande e problemi.
Iniziamo dal principio:
appena tento il boot grub non riesce a caricarsi (tenta di caricare lo stage1.5) e mi da error 17. Ho provato a fare un po' di ricerche ma non ho risolto niente.
Posto il contenuto di menu.lst:

timeout 1
color black/cyan
default 0
title Debian 2.6.9
root (hd1,0)
kernel /boot/vmlinuz-2.6.9-kanotix-8 root=/dev/hdb1 ro lang=it apm=power-off vga=0x317

Mi potreste aiutare?

se può aiutare: praticamente con la stessa configurazione se faccio il boot da floppy funziona, però mi carica stage2

iacchi
12-02-2005, 12:50
Se può aiutare: io come boot loader principale uso xosl, e se seleziono per il boot di linux il corrispettivo di hdb1, mi si riavvia il pc; se seleziono hdb mi da l'errore sopracitato.

Una domanda: perché il mio file di configurazione si chiama menu.lst e non grub.conf?

Nophiq
23-06-2005, 20:56
Posso risponderti soltanto ad una cosa: il contenuto di grub.conf è uguale a menu.lst; la differenza sta nel fatto che durante il caricamento grub.conf richiama menu.lst

Anche a me viene lo stesso Error 17 che non mi fa partire niente; vorrei chiederti come hai fatto a creare un disco floppy che ti faccia partire il Grub 2 perchè quando inserisco il mio, mi si avvia solamente la linea di comando.

andy caps
23-06-2005, 21:17
errore 17 sembra dipenda dal fatto che non riconosce il filesystem della partizione

dopo avere avviato da floppy controlla con fdisk -l come vede le partizioni

a qualcuno succede che non riconoscendo il controller disco mette hdb come hda e dovresti cosi correggere grub con hda1 eventualmente


se apt ti trova disponibile lilo
apt-cache search lilo

installalo e poi dai un liloconfig

lilo da meno problemi d grub secondo me

iacchi
24-06-2005, 00:58
onestamente è passato tanto tempo da questa discussione e non mi ricordo bene come stavano le cose. Tuttavia: il floppy di avvio l'ho creato in installazione, e ho risolto semplicemente reinstallando grub nel posto che mi serviva da riga di comando una volta avviato il sistema

Loading