PDA

Visualizza la versione completa : [UBUNTU] Scaricare pacchetti da internet


c montecristo
12-02-2005, 19:31
Beh... un apt-get install installa la roba che scelgo dal cd (se ne e' rimasta). Ho provato a guarda "/etc/apt/sources.list" ma scarica ugualmente dal cd, o peggio, scarica da internet ma non trova i pacchetti Apache e PHP. :(

Come faccio?

francofait
12-02-2005, 19:36
Originariamente inviato da c montecristo
Beh... un apt-get install installa la roba che scelgo dal cd (se ne e' rimasta). Ho provato a guarda "/etc/apt/sources.list" ma scarica ugualmente dal cd, o peggio, scarica da internet ma non trova i pacchetti Apache e PHP. :(

Come faccio?

Impossibile che non ci sia

se ti va a cercare cdrom evidente che nel source list hai la chiamata alle periferiche cdrom abilitata , commentala.
E usa Synaptic serve apposta per avere in vista tutti i pacchetti disponibili installati e no.

bakuryu
12-02-2005, 20:29
posta un p /etc/apt/sources.list

Mutato
13-02-2005, 05:41
devi indicare universe come repository

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe

c montecristo
13-02-2005, 16:29
boris@localhost:~ $ sudo -s
Password:
root@localhost:~ # apt-get install apache php4
Reading Package Lists... Done
Building Dependency Tree... Done
Package apache is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
apache-common
E: Package apache has no installation candidate
root@localhost:~ #


:bh:

c montecristo
13-02-2005, 16:32
Adesso ho modificato /etc/apt/sources.list e questo e' l'errore:



root@localhost:~ # apt-get install apache php4
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
apache: Depends: apache-common (>= 1.3.31-6) but it is not installable
Depends: apache-common (< 1.3.32-0) but it is not installable
php4: Depends: libmm13 but it is not installable
Depends: apache-common (>= 1.3.31) but it is not installable
E: Broken packages
root@localhost:~ #


Questo e' l'apt sources.list:



# deb cdrom:[Ubuntu 4.10 _Warty Warthog_ - Preview i386 Binary-1 (20041020)]/ unstable main restricted


## Uncomment the following two lines to fetch updated software from the network
## deb http://archive.ubuntu.com/ubuntu warty main restricted
## deb-src http://archive.ubuntu.com/ubuntu warty main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu warty universe
deb-src http://archive.ubuntu.com/ubuntu warty universe

# deb http://security.ubuntu.com/ubuntu warty-security main restricted
# deb-src http://security.ubuntu.com/ubuntu warty-security main restricted


Come risolvo?

c montecristo
13-02-2005, 16:53
up

andy caps
13-02-2005, 17:05
magari decommenta le righe in alto poi dai un apt-get update

## deb http://archive.ubuntu.com/ubuntu warty main restricted
## deb-src http://archive.ubuntu.com/ubuntu warty main restricted

Pegasus
13-02-2005, 21:15
Installa questi :)

apache2
libapache2-mod-php4
mysql-server

Neon87
13-02-2005, 21:23
a me aveva fatto una roba simile su debian... ho commentato tutte le stringhe di sources.list e ho dato un apt-get update
poi ho decommentato solo quelle che mi servivano e ho ridato un apt-get update

poi ha funzionato tutto alla perfezione...

Loading